summaryrefslogtreecommitdiffstats
path: root/src/anvil/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/anvil/Makefile.am')
-rw-r--r--src/anvil/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/src/anvil/Makefile.am b/src/anvil/Makefile.am
new file mode 100644
index 0000000..1af526f
--- /dev/null
+++ b/src/anvil/Makefile.am
@@ -0,0 +1,48 @@
+pkglibexecdir = $(libexecdir)/dovecot
+
+pkglibexec_PROGRAMS = anvil
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/lib \
+ -I$(top_srcdir)/src/lib-test \
+ -I$(top_srcdir)/src/lib-settings \
+ -I$(top_srcdir)/src/lib-master \
+ $(BINARY_CFLAGS)
+
+anvil_LDADD = \
+ $(LIBDOVECOT) \
+ $(RAND_LIBS) \
+ $(BINARY_LDFLAGS)
+
+anvil_DEPENDENCIES = $(LIBDOVECOT_DEPS)
+
+anvil_SOURCES = \
+ main.c \
+ anvil-connection.c \
+ anvil-settings.c \
+ connect-limit.c \
+ penalty.c
+
+noinst_HEADERS = \
+ anvil-connection.h \
+ common.h \
+ connect-limit.h \
+ penalty.h
+
+test_programs = \
+ test-penalty
+
+noinst_PROGRAMS = $(test_programs)
+
+test_libs = \
+ ../lib-test/libtest.la \
+ ../lib/liblib.la
+
+test_penalty_SOURCES = test-penalty.c
+test_penalty_LDADD = penalty.o $(test_libs)
+test_penalty_DEPENDENCIES = $(pkglibexec_PROGRAMS) $(test_libs)
+
+check-local:
+ for bin in $(test_programs); do \
+ if ! $(RUN_TEST) ./$$bin; then exit 1; fi; \
+ done