summaryrefslogtreecommitdiffstats
path: root/src/replication/aggregator/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/replication/aggregator/Makefile.am')
-rw-r--r--src/replication/aggregator/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/replication/aggregator/Makefile.am b/src/replication/aggregator/Makefile.am
new file mode 100644
index 0000000..a0b3501
--- /dev/null
+++ b/src/replication/aggregator/Makefile.am
@@ -0,0 +1,29 @@
+pkglibexecdir = $(libexecdir)/dovecot
+
+pkglibexec_PROGRAMS = aggregator
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/lib \
+ -I$(top_srcdir)/src/lib-settings \
+ -I$(top_srcdir)/src/lib-auth \
+ -I$(top_srcdir)/src/lib-master \
+ -I$(top_srcdir)/src/replication \
+ -DPKG_STATEDIR=\""$(statedir)"\" \
+ $(BINARY_CFLAGS)
+
+aggregator_LDFLAGS = -export-dynamic \
+ $(BINARY_LDFLAGS)
+
+aggregator_LDADD = $(LIBDOVECOT)
+aggregator_DEPENDENCIES = $(LIBDOVECOT_DEPS)
+
+aggregator_SOURCES = \
+ aggregator.c \
+ aggregator-settings.c \
+ notify-connection.c \
+ replicator-connection.c
+
+noinst_HEADERS = \
+ aggregator-settings.h \
+ notify-connection.h \
+ replicator-connection.h