summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:40:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:40:39 +0000
commitca2f47455d28c0607e2e0204a0176cd2a322ea75 (patch)
tree0590c3b61fb246c870809b92706d962f522614d0
parentMerging upstream version 1.22.5. (diff)
downloaddpkg-ca2f47455d28c0607e2e0204a0176cd2a322ea75.tar.xz
dpkg-ca2f47455d28c0607e2e0204a0176cd2a322ea75.zip
Merging debian version 1.22.5.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog61
-rw-r--r--debian/control12
2 files changed, 67 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 1d905e9..7e0d4ac 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,64 @@
+dpkg (1.22.5) unstable; urgency=medium
+
+ [ Guillem Jover ]
+ * dpkg-buildapi: Remove -v alias for --version.
+ * dpkg-query: Fix exit codes for --show. Closes: #1064036
+ * Perl modules:
+ - Dpkg::OpenPGP::Backend::Sequoia: Update to new CLI API changes.
+ - Dpkg::OpenPGP::Backend::GnuPG: Add support for Sequoia gpg Chameleon.
+ - Dpkg::Vendor::Debian: Only append branch compiler flags if $flag is set.
+ - Dpkg::Vendor: Make the add_build_flags() a non-private method.
+ - Dpkg::Vendor::Ubuntu: Pass compiler flags to disable features.
+ Based on a patch by Matthias Klose <doko@ubuntu.com>.
+ - Dpkg::Vendor::Debian: Enable time64 feature by default except on
+ <some>-i386. Closes: #1037136
+ Based on a patch by Steve Langasek <steve.langasek@ubuntu.com>.
+ - Dpkg::Vendor::Debian: Enable qa=+bug-implicit-func for abi=+time64
+ feature. Based on a patch by Steve Langasek <steve.langasek@ubuntu.com>.
+ * Documentation:
+ - man, doc: Fix dpkg-buildapi option and command grouping in descriptions.
+ - man: Add spaces around make variable assignments.
+ - man: Do not duplicate list of known feature areas in dpkg-buildflags.
+ - man: Document known feature areas in DEB_BUILD_OPTIONS for
+ dpkg-buildpackage.
+ - man: Improve build flags feature specification in environment variables.
+ Closes: #1063641
+ - man: Use L</> markup for inter link reference.
+ - man: Mention Build-Depends-Packages in dpkg-shlibdeps(1).
+ * Code internals:
+ - libdpkg: Add comment clarifying GNU long name tar format expectations.
+ - libdpkg: Use an intermediate mode variable in secure_unlink_statted().
+ - dpkg: Rename symlink_len to linksize.
+ - dpkg: Rename r variable for readlink() return value to linksize.
+ - dpkg: Reduce variable scope in conffderef().
+ - libdpkg: Refactor file_readlink() function.
+ - libdpkg: Deindent an else clause.
+ - lib, src: Fold if with last previous else.
+ - perl: Fold if into previous else.
+ - dpkg-mergechangelogs: Refactor merge_tail() sub from anonymous sub.
+ - dpkg-query: Rename rc variables tracking no matches to misses.
+ - dpkg-query: Rename failures variables tracking no matches to misses.
+ * Build system:
+ - Rename pkexec variables to polkitactions.
+ - Move directory definitions to configure.
+ - Use PACKAGE_TARNAME for pathname components in directories.
+ - Split each automake variable value into its own line.
+ - Reorder automake variables.
+ - Move update-alternatives rules within automake conditional.
+ - Move MD_LIBS from LDFLAGS to LDADD for libdpkg.
+ - Fix libdpkg library flags for static and dynamic linking.
+ - Add infrastructure for bash-completions.
+ * Test suite:
+ - Pass -T+1 to xz to workaround spurious warning with xz 5.6.0.
+ Closes: #1064856
+
+ [ Helge Kreutzmann ]
+ * Localization:
+ - Update German man pages translation.
+ - Update German scripts translation.
+
+ -- Guillem Jover <guillem@debian.org> Tue, 27 Feb 2024 04:28:03 +0100
+
dpkg (1.22.4-0.0~progress7.99u1) graograman-backports; urgency=medium
* Initial reupload to graograman-backports.
diff --git a/debian/control b/debian/control
index a31f2d8..615da60 100644
--- a/debian/control
+++ b/debian/control
@@ -127,8 +127,8 @@ Recommends:
build-essential,
gcc | c-compiler,
fakeroot,
- gnupg | sq | sqop | pgpainless-cli,
- gpgv | sq | sqop | pgpainless-cli,
+ gnupg | sq | sqop | pgpainless-cli | sequoia-chameleon-gnupg,
+ gpgv | sq | sqop | pgpainless-cli | sequoia-chameleon-gnupg,
# Used by dpkg-mergechangelogs.
libalgorithm-merge-perl,
Suggests:
@@ -137,7 +137,7 @@ Breaks:
# Force R³ support, w/o requiring debhelper users to depend on dpkg-dev.
debhelper (<< 10.10.1~),
# Uses new sq features, w/o requiring a hard dependency on sq.
- sq (<< 0.28.0~),
+ sq (<< 0.33.0~),
# Uses required SOP features, w/o requiring a hard dependency on sqop.
sqop (<< 0.27.2~),
# Uses required SOP features, w/o requiring a hard dependency on pgpainless.
@@ -173,8 +173,8 @@ Recommends:
xz-utils (>= 5.4.0),
Suggests:
debian-keyring,
- gnupg | sq | sqop | pgpainless-cli,
- gpgv | sq | sqop | pgpainless-cli,
+ gnupg | sq | sqop | pgpainless-cli | sequoia-chameleon-gnupg,
+ gpgv | sq | sqop | pgpainless-cli | sequoia-chameleon-gnupg,
gcc | c-compiler,
binutils,
patch,
@@ -192,7 +192,7 @@ Breaks:
# versions prior to 1.19.0.
dgit (<< 3.13~),
# Uses new sq features, w/o requiring a hard dependency on sq.
- sq (<< 0.28.0~),
+ sq (<< 0.33.0~),
# Uses required SOP features, w/o requiring a hard dependency on sqop.
sqop (<< 0.27.2~),
# Uses required SOP features, w/o requiring a hard dependency on pgpainless.