summaryrefslogtreecommitdiffstats
path: root/scripts/mk/buildapi.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:35:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:35:28 +0000
commitea314d2f45c40a006c0104157013ab4b857f665f (patch)
tree3ef2971cb3675c318b8d9effd987854ad3f6d3e8 /scripts/mk/buildapi.mk
parentInitial commit. (diff)
downloaddpkg-ea314d2f45c40a006c0104157013ab4b857f665f.tar.xz
dpkg-ea314d2f45c40a006c0104157013ab4b857f665f.zip
Adding upstream version 1.22.4.upstream/1.22.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'scripts/mk/buildapi.mk')
-rw-r--r--scripts/mk/buildapi.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/scripts/mk/buildapi.mk b/scripts/mk/buildapi.mk
new file mode 100644
index 0000000..668e325
--- /dev/null
+++ b/scripts/mk/buildapi.mk
@@ -0,0 +1,9 @@
+# This Makefile fragment (since dpkg 1.22.0) handles the build API.
+
+# Default API level when not set.
+DPKG_BUILD_API ?= $(shell dpkg-buildapi)
+
+# We could use only built-in GNU make functions, but that seems too much
+# complexity given no integer operators, given that we currently have to
+# fetch the build API level anyway.
+dpkg_build_api_ge = $(shell test "$(DPKG_BUILD_API)" -ge "$(1)" && echo yes)