summaryrefslogtreecommitdiffstats
path: root/scripts/mk/buildopts.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:35:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:35:28 +0000
commitea314d2f45c40a006c0104157013ab4b857f665f (patch)
tree3ef2971cb3675c318b8d9effd987854ad3f6d3e8 /scripts/mk/buildopts.mk
parentInitial commit. (diff)
downloaddpkg-ea314d2f45c40a006c0104157013ab4b857f665f.tar.xz
dpkg-ea314d2f45c40a006c0104157013ab4b857f665f.zip
Adding upstream version 1.22.4.upstream/1.22.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'scripts/mk/buildopts.mk')
-rw-r--r--scripts/mk/buildopts.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/scripts/mk/buildopts.mk b/scripts/mk/buildopts.mk
new file mode 100644
index 0000000..c957777
--- /dev/null
+++ b/scripts/mk/buildopts.mk
@@ -0,0 +1,10 @@
+# This Makefile fragment (since dpkg 1.20.1) parses option arguments from
+# DEB_BUILD_OPTIONS, and exposes these as variables.
+#
+# Defines the following variables:
+#
+# DEB_BUILD_OPTION_PARALLEL: the argument for the parallel=N option.
+
+ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+ DEB_BUILD_OPTION_PARALLEL = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+endif