summaryrefslogtreecommitdiffstats
path: root/scripts/t/mk/vendor.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-07 13:30:11 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-07 13:30:11 +0000
commitb4f7d8b1566e3220d0e9004499ef9c257e079c57 (patch)
treece0468ca8cf21380bef3d2aaacc9fcb30116e757 /scripts/t/mk/vendor.mk
parentReleasing progress-linux version 1.22.6-0.0~progress7.99u1. (diff)
downloaddpkg-b4f7d8b1566e3220d0e9004499ef9c257e079c57.tar.xz
dpkg-b4f7d8b1566e3220d0e9004499ef9c257e079c57.zip
Merging upstream version 1.22.7.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'scripts/t/mk/vendor.mk')
-rw-r--r--scripts/t/mk/vendor.mk17
1 files changed, 14 insertions, 3 deletions
diff --git a/scripts/t/mk/vendor.mk b/scripts/t/mk/vendor.mk
index 4e0d9ff..9d89f0f 100644
--- a/scripts/t/mk/vendor.mk
+++ b/scripts/t/mk/vendor.mk
@@ -1,6 +1,17 @@
include $(srcdir)/mk/vendor.mk
-test:
- test "$(DEB_VENDOR)" = "Debian"
- test "$(DEB_PARENT_VENDOR)" = ""
+TEST_DEB_VENDOR = Debian
+TEST_DEB_PARENT_VENDOR =
+
+test_vars := \
+ DEB_VENDOR \
+ DEB_PARENT_VENDOR \
+ # EOL
+
+test: $(test_vars)
+ : # Test the dpkg_vendor_derives_from macro.
test "$(shell $(call dpkg_vendor_derives_from,debian))" = "yes"
+
+$(test_vars):
+ : # Test $@ Make variable.
+ test '$($@)' = '$(TEST_$@)'