summaryrefslogtreecommitdiffstats
path: root/tests/t-breaks-multiarch
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:35:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:35:28 +0000
commitea314d2f45c40a006c0104157013ab4b857f665f (patch)
tree3ef2971cb3675c318b8d9effd987854ad3f6d3e8 /tests/t-breaks-multiarch
parentInitial commit. (diff)
downloaddpkg-ea314d2f45c40a006c0104157013ab4b857f665f.tar.xz
dpkg-ea314d2f45c40a006c0104157013ab4b857f665f.zip
Adding upstream version 1.22.4.upstream/1.22.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-breaks-multiarch')
-rw-r--r--tests/t-breaks-multiarch/Makefile22
-rw-r--r--tests/t-breaks-multiarch/lib-a-0-amd64/DEBIAN/control8
-rw-r--r--tests/t-breaks-multiarch/lib-a-0-i386/DEBIAN/control8
-rw-r--r--tests/t-breaks-multiarch/lib-a-1-amd64/DEBIAN/control8
-rw-r--r--tests/t-breaks-multiarch/lib-a-1-i386/DEBIAN/control8
-rw-r--r--tests/t-breaks-multiarch/lib-b-0-amd64/DEBIAN/control8
-rw-r--r--tests/t-breaks-multiarch/lib-b-0-i386/DEBIAN/control8
-rw-r--r--tests/t-breaks-multiarch/lib-b-1-amd64/DEBIAN/control8
-rw-r--r--tests/t-breaks-multiarch/lib-b-1-i386/DEBIAN/control8
-rw-r--r--tests/t-breaks-multiarch/pkg-c/DEBIAN/control8
10 files changed, 94 insertions, 0 deletions
diff --git a/tests/t-breaks-multiarch/Makefile b/tests/t-breaks-multiarch/Makefile
new file mode 100644
index 0000000..344e05a
--- /dev/null
+++ b/tests/t-breaks-multiarch/Makefile
@@ -0,0 +1,22 @@
+TESTS_DEB := lib-a-0-amd64 lib-a-0-i386 \
+ lib-a-1-amd64 lib-a-1-i386 \
+ lib-b-0-amd64 lib-b-0-i386 \
+ lib-b-1-amd64 lib-b-1-i386 \
+ pkg-c
+
+include ../Test.mk
+
+DPKG_OPTIONS += --auto-deconfigure
+
+test-case:
+ $(DPKG) --add-architecture i386
+ $(DPKG_INSTALL) lib-a-0-amd64.deb lib-a-0-i386.deb
+ $(DPKG_INSTALL) lib-b-0-amd64.deb lib-b-0-i386.deb
+ $(DPKG_INSTALL) pkg-c.deb \
+ lib-a-1-amd64.deb lib-a-1-i386.deb \
+ lib-b-1-amd64.deb lib-b-1-i386.deb
+
+test-clean:
+ $(DPKG_PURGE) lib-a:amd64 lib-a:i386 lib-b:amd64 lib-b:i386 pkg-c
+ $(DPKG) --remove-architecture i386
+ rm -f $(DPKG_ADMINDIR)/arch
diff --git a/tests/t-breaks-multiarch/lib-a-0-amd64/DEBIAN/control b/tests/t-breaks-multiarch/lib-a-0-amd64/DEBIAN/control
new file mode 100644
index 0000000..8f91a57
--- /dev/null
+++ b/tests/t-breaks-multiarch/lib-a-0-amd64/DEBIAN/control
@@ -0,0 +1,8 @@
+Package: lib-a
+Version: 0
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: amd64
+Multi-Arch: same
+Description: test package - broken package
diff --git a/tests/t-breaks-multiarch/lib-a-0-i386/DEBIAN/control b/tests/t-breaks-multiarch/lib-a-0-i386/DEBIAN/control
new file mode 100644
index 0000000..0a8db71
--- /dev/null
+++ b/tests/t-breaks-multiarch/lib-a-0-i386/DEBIAN/control
@@ -0,0 +1,8 @@
+Package: lib-a
+Version: 0
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: i386
+Multi-Arch: same
+Description: test package - broken package
diff --git a/tests/t-breaks-multiarch/lib-a-1-amd64/DEBIAN/control b/tests/t-breaks-multiarch/lib-a-1-amd64/DEBIAN/control
new file mode 100644
index 0000000..dca3d18
--- /dev/null
+++ b/tests/t-breaks-multiarch/lib-a-1-amd64/DEBIAN/control
@@ -0,0 +1,8 @@
+Package: lib-a
+Version: 1
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: amd64
+Multi-Arch: same
+Description: test package - broken package
diff --git a/tests/t-breaks-multiarch/lib-a-1-i386/DEBIAN/control b/tests/t-breaks-multiarch/lib-a-1-i386/DEBIAN/control
new file mode 100644
index 0000000..2af8f28
--- /dev/null
+++ b/tests/t-breaks-multiarch/lib-a-1-i386/DEBIAN/control
@@ -0,0 +1,8 @@
+Package: lib-a
+Version: 1
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: i386
+Multi-Arch: same
+Description: test package - broken package
diff --git a/tests/t-breaks-multiarch/lib-b-0-amd64/DEBIAN/control b/tests/t-breaks-multiarch/lib-b-0-amd64/DEBIAN/control
new file mode 100644
index 0000000..ebfcac3
--- /dev/null
+++ b/tests/t-breaks-multiarch/lib-b-0-amd64/DEBIAN/control
@@ -0,0 +1,8 @@
+Package: lib-b
+Version: 0
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: amd64
+Multi-Arch: same
+Description: test package - broken package
diff --git a/tests/t-breaks-multiarch/lib-b-0-i386/DEBIAN/control b/tests/t-breaks-multiarch/lib-b-0-i386/DEBIAN/control
new file mode 100644
index 0000000..52dd252
--- /dev/null
+++ b/tests/t-breaks-multiarch/lib-b-0-i386/DEBIAN/control
@@ -0,0 +1,8 @@
+Package: lib-b
+Version: 0
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: i386
+Multi-Arch: same
+Description: test package - broken package
diff --git a/tests/t-breaks-multiarch/lib-b-1-amd64/DEBIAN/control b/tests/t-breaks-multiarch/lib-b-1-amd64/DEBIAN/control
new file mode 100644
index 0000000..970a873
--- /dev/null
+++ b/tests/t-breaks-multiarch/lib-b-1-amd64/DEBIAN/control
@@ -0,0 +1,8 @@
+Package: lib-b
+Version: 1
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: amd64
+Multi-Arch: same
+Description: test package - broken package
diff --git a/tests/t-breaks-multiarch/lib-b-1-i386/DEBIAN/control b/tests/t-breaks-multiarch/lib-b-1-i386/DEBIAN/control
new file mode 100644
index 0000000..7ceb7d4
--- /dev/null
+++ b/tests/t-breaks-multiarch/lib-b-1-i386/DEBIAN/control
@@ -0,0 +1,8 @@
+Package: lib-b
+Version: 1
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: i386
+Multi-Arch: same
+Description: test package - broken package
diff --git a/tests/t-breaks-multiarch/pkg-c/DEBIAN/control b/tests/t-breaks-multiarch/pkg-c/DEBIAN/control
new file mode 100644
index 0000000..95ebbac
--- /dev/null
+++ b/tests/t-breaks-multiarch/pkg-c/DEBIAN/control
@@ -0,0 +1,8 @@
+Package: pkg-c
+Version: 0
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Breaks: lib-b (<< 1)
+Description: test package - breaking package