summaryrefslogtreecommitdiffstats
path: root/tests/t-buildinfo/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:35:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:35:28 +0000
commitea314d2f45c40a006c0104157013ab4b857f665f (patch)
tree3ef2971cb3675c318b8d9effd987854ad3f6d3e8 /tests/t-buildinfo/Makefile
parentInitial commit. (diff)
downloaddpkg-ea314d2f45c40a006c0104157013ab4b857f665f.tar.xz
dpkg-ea314d2f45c40a006c0104157013ab4b857f665f.zip
Adding upstream version 1.22.4.upstream/1.22.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-buildinfo/Makefile')
-rw-r--r--tests/t-buildinfo/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/t-buildinfo/Makefile b/tests/t-buildinfo/Makefile
new file mode 100644
index 0000000..019d850
--- /dev/null
+++ b/tests/t-buildinfo/Makefile
@@ -0,0 +1,11 @@
+OPTS = --admindir=$(CURDIR)/db-buildinfo
+
+test:
+ touch test-binary-a_1.0_amd64.deb
+ dpkg-source -b pkg-source
+ cd pkg-source && DEB_HOST_ARCH=amd64 dpkg-checkbuilddeps $(OPTS)
+ cd pkg-source && DEB_HOST_ARCH=amd64 dpkg-genbuildinfo $(OPTS)
+
+test-clean:
+ rm -f *.dsc *.deb *.buildinfo
+ rm -f *.tar.xz