summaryrefslogtreecommitdiffstats
path: root/tests/t-conffile-replaces-diverted/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:35:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:35:28 +0000
commitea314d2f45c40a006c0104157013ab4b857f665f (patch)
tree3ef2971cb3675c318b8d9effd987854ad3f6d3e8 /tests/t-conffile-replaces-diverted/Makefile
parentInitial commit. (diff)
downloaddpkg-ea314d2f45c40a006c0104157013ab4b857f665f.tar.xz
dpkg-ea314d2f45c40a006c0104157013ab4b857f665f.zip
Adding upstream version 1.22.4.upstream/1.22.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-conffile-replaces-diverted/Makefile')
-rw-r--r--tests/t-conffile-replaces-diverted/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/tests/t-conffile-replaces-diverted/Makefile b/tests/t-conffile-replaces-diverted/Makefile
new file mode 100644
index 0000000..5e9b176
--- /dev/null
+++ b/tests/t-conffile-replaces-diverted/Makefile
@@ -0,0 +1,18 @@
+TESTS_DEB := pkg-conff-0 pkg-conff-1 pkg-conff-move
+
+include ../Test.mk
+
+DPKG_DIVERT_OPTIONS += --local --rename --divert /test/conffile.moved
+
+test-case:
+ $(DPKG_INSTALL) pkg-conff-0.deb
+ $(DPKG_DIVERT_ADD) /test/conffile
+ test -f '$(DPKG_INSTDIR)/test/conffile.moved'
+ # Test if the other package can takeover a diverted conffile w/o error.
+ $(DPKG_INSTALL) pkg-conff-1.deb
+ $(DPKG_INSTALL) pkg-conff-move.deb
+
+test-clean:
+ $(DPKG_DIVERT_DEL) /test/conffile
+ $(DPKG_PURGE) pkg-conff
+ $(DPKG_PURGE) pkg-conff-move