summaryrefslogtreecommitdiffstats
path: root/tests/t-provides
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-07 13:30:11 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-07 13:30:11 +0000
commitb4f7d8b1566e3220d0e9004499ef9c257e079c57 (patch)
treece0468ca8cf21380bef3d2aaacc9fcb30116e757 /tests/t-provides
parentReleasing progress-linux version 1.22.6-0.0~progress7.99u1. (diff)
downloaddpkg-b4f7d8b1566e3220d0e9004499ef9c257e079c57.tar.xz
dpkg-b4f7d8b1566e3220d0e9004499ef9c257e079c57.zip
Merging upstream version 1.22.7.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-provides')
-rw-r--r--tests/t-provides/Makefile15
-rw-r--r--tests/t-provides/pkg-provides-bogus/DEBIAN/control8
2 files changed, 22 insertions, 1 deletions
diff --git a/tests/t-provides/Makefile b/tests/t-provides/Makefile
index 6794c20..76e3073 100644
--- a/tests/t-provides/Makefile
+++ b/tests/t-provides/Makefile
@@ -8,6 +8,17 @@ TESTS_DEB := \
include ../Test.mk
+test-bogus:
+ # test building with bogus provides
+ ! $(DPKG_BUILD_DEB) pkg-provides-bogus
+
+ # build bogus packages
+ $(DPKG_BUILD_DEB) --nocheck pkg-provides-bogus
+
+ # test installing packages with bogus provides
+ ! $(DPKG_INSTALL) pkg-provides-bogus.deb
+ $(call pkg_is_not_installed,pkg-provides-bogus)
+
define PURGE_DEPENDS
$(DPKG_PURGE) pkg-depends
$(DPKG_PURGE) pkg-depends-le
@@ -282,7 +293,7 @@ test-conflicts:
# The provided predependency is removed, pass
$(DPKG_PURGE) pkg-provides
-test-case: test-depends test-predepends test-breaks test-conflicts
+test-case: test-bogus test-depends test-predepends test-breaks test-conflicts
test-clean:
-$(DPKG_PURGE) pkg-depends
@@ -305,3 +316,5 @@ test-clean:
-$(DPKG_PURGE) pkg-a-depends-ge-lt
-$(DPKG_PURGE) pkg-b-provides
-$(DPKG_PURGE) pkg-c-provides
+
+ rm -f pkg-provides-bogus.deb
diff --git a/tests/t-provides/pkg-provides-bogus/DEBIAN/control b/tests/t-provides/pkg-provides-bogus/DEBIAN/control
new file mode 100644
index 0000000..a64ab77
--- /dev/null
+++ b/tests/t-provides/pkg-provides-bogus/DEBIAN/control
@@ -0,0 +1,8 @@
+Package: pkg-provides-bogus
+Version: 0
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Provides: pkg-virtual-bogus (>= 1.0)
+Description: test package - package providing a bogus virtual package