summaryrefslogtreecommitdiffstats
path: root/tests/t-unpack-fifo
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:35:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 18:35:28 +0000
commitea314d2f45c40a006c0104157013ab4b857f665f (patch)
tree3ef2971cb3675c318b8d9effd987854ad3f6d3e8 /tests/t-unpack-fifo
parentInitial commit. (diff)
downloaddpkg-ea314d2f45c40a006c0104157013ab4b857f665f.tar.xz
dpkg-ea314d2f45c40a006c0104157013ab4b857f665f.zip
Adding upstream version 1.22.4.upstream/1.22.4
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/t-unpack-fifo')
-rw-r--r--tests/t-unpack-fifo/Makefile22
-rw-r--r--tests/t-unpack-fifo/pkg-fifo/DEBIAN/control8
2 files changed, 30 insertions, 0 deletions
diff --git a/tests/t-unpack-fifo/Makefile b/tests/t-unpack-fifo/Makefile
new file mode 100644
index 0000000..eaa848a
--- /dev/null
+++ b/tests/t-unpack-fifo/Makefile
@@ -0,0 +1,22 @@
+PKG := pkg-fifo
+
+TESTS_DEB := pkg-fifo
+
+include ../Test.mk
+
+$(PKG)/test-fifo:
+ mkfifo $@
+
+build-hook: $(PKG)/test-fifo
+
+clean-hook:
+ rm -f $(PKG)/test-fifo
+
+test-case:
+ # test unpacking a fifo
+ $(DPKG_INSTALL) pkg-fifo.deb
+ $(call pkg_is_installed,pkg-fifo)
+
+test-clean:
+ $(DPKG_PURGE) pkg-fifo
+
diff --git a/tests/t-unpack-fifo/pkg-fifo/DEBIAN/control b/tests/t-unpack-fifo/pkg-fifo/DEBIAN/control
new file mode 100644
index 0000000..8087b89
--- /dev/null
+++ b/tests/t-unpack-fifo/pkg-fifo/DEBIAN/control
@@ -0,0 +1,8 @@
+Package: pkg-fifo
+Version: 0.0-1
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Description: test package - unpacking fifo
+