summaryrefslogtreecommitdiffstats
path: root/man/dpkg-buildtree.pod
diff options
context:
space:
mode:
Diffstat (limited to 'man/dpkg-buildtree.pod')
-rw-r--r--man/dpkg-buildtree.pod98
1 files changed, 98 insertions, 0 deletions
diff --git a/man/dpkg-buildtree.pod b/man/dpkg-buildtree.pod
new file mode 100644
index 0000000..660ebb0
--- /dev/null
+++ b/man/dpkg-buildtree.pod
@@ -0,0 +1,98 @@
+# dpkg manual page - dpkg-buildtree(1)
+#
+# Copyright © 2023 Guillem Jover <guillem@debian.org>
+#
+# This is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+=encoding utf8
+
+=head1 NAME
+
+dpkg-buildtree - helper for build tree operations during package builds
+
+=head1 SYNOPSIS
+
+B<dpkg-buildtree> [I<option>...] [I<command>]
+
+=head1 DESCRIPTION
+
+B<dpkg-buildtree> is a tool to perform common operations on the build tree
+for a source package.
+
+This program was introduced in dpkg 1.22.3.
+
+=head1 COMMANDS
+
+=over
+
+=item B<clean>
+
+Removes all artifacts generated during a build by the various dpkg tools,
+and pathnames used or controlled by dpkg tools that are safe to clean.
+These files are used to track state between package build runs,
+and are in many cases internal implementation details the packager should
+not be concerned about,
+or are staging directories containing build artifacts.
+
+=item B<--help>
+
+Show the usage message and exit.
+
+=item B<--version>
+
+Show the version and exit.
+
+=back
+
+=head1 FILES
+
+=head2 Cleaned files
+
+=over
+
+=item F<debian/files>
+
+=item F<debian/files.new>
+
+Files generated by L<dpkg-distaddfile(1)>.
+
+=item F<debian/substvars>
+
+=item F<debian/substvars.new>
+
+Files generated by L<dpkg-shlibdeps(1)>.
+
+=item F<debian/tmp>
+
+Staging directory containing the contents to be used when creating a package.
+Both L<dpkg-gencontrol(1)> and L<dpkg-gensymbols(1)> generate files within.
+
+=back
+
+=head1 EXAMPLES
+
+=head2 Usage in debian/rules
+
+You can call B<dpkg-buildtree clean> from the F<debian/rules> B<clean> target,
+after having performed other necessary cleanups.
+
+For example for an autoconf-like build system:
+
+=over
+
+ clean:
+ [ ! -f Makefile ] || $(MAKE) distclean
+ dpkg-buildtree clean
+
+=back