summaryrefslogtreecommitdiffstats
path: root/man/sv
diff options
context:
space:
mode:
Diffstat (limited to 'man/sv')
-rw-r--r--man/sv/dpkg-buildapi.pod14
-rw-r--r--man/sv/dpkg-buildflags.pod31
-rw-r--r--man/sv/dpkg-buildpackage.pod18
-rw-r--r--man/sv/dpkg-parsechangelog.pod2
-rw-r--r--man/sv/dpkg-shlibdeps.pod2
5 files changed, 55 insertions, 12 deletions
diff --git a/man/sv/dpkg-buildapi.pod b/man/sv/dpkg-buildapi.pod
index 2c40542..cf02e43 100644
--- a/man/sv/dpkg-buildapi.pod
+++ b/man/sv/dpkg-buildapi.pod
@@ -30,10 +30,6 @@ Kommandot introducerades i dpkg 1.22.0.
=over
-=item B<-c>I<control-fil>
-
-Anger huvudkällkodsstyrfilen som information ska läsas från. Standardvärdet är B<debian/control>.
-
=item B<--help>
Visar hjälpskärm och avslutar.
@@ -44,6 +40,16 @@ Visar version och avslutar.
=back
+=head1 FLAGGOR
+
+=over
+
+=item B<-c>I<control-fil>
+
+Anger huvudkällkodsstyrfilen som information ska läsas från. Standardvärdet är B<debian/control>.
+
+=back
+
=head1 MILJÖVARIABLER
=over
diff --git a/man/sv/dpkg-buildflags.pod b/man/sv/dpkg-buildflags.pod
index 4c8e4ff..e49cece 100644
--- a/man/sv/dpkg-buildflags.pod
+++ b/man/sv/dpkg-buildflags.pod
@@ -179,7 +179,7 @@ Till exempel:
=item B<--query-features> I<område>
-Skriv ut funktioner aktiverade för ett givet område (sedan dpkg 1.16.2). Om funktionen hanteras (även om bara av några arkitekturer) som ett inbyggt förval av kompilatorn visas fältet B<Bultin> (sedan dpkg 1.21.14). De enda för närvarande kända områdena på Debian och dess derivat är B<future>, B<qa>, B<reproducible>, B<sanitize> och B<hardening>, se avsnittet B<FUNKTIONSOMRÅDEN> för fler detaljer. Avslutar med 0 om området är känt, avslutar annars med 1.
+Print the features enabled for a given area (since dpkg 1.16.2). If the feature is handled (even if only on some architectures) as a builtin default by the compiler, then a B<Builtin> field is printed (since dpkg 1.21.14). See the L</FEATURE AREAS> section for more details about the currently recognized areas. Exits with 0 if the area is known otherwise exits with 1.
Utdata är på RFC822-headerformat, med en sektion per funktion. Till exempel:
@@ -290,13 +290,30 @@ Nya flaggor kan komma att läggas till i framtiden om behovet uppstår (till exe
=head1 FUNKTIONSOMRÅDEN
-Varje områdesfunktion kan aktiveras och inaktiveras i områdesvärdet i miljövariablerna B<DEB_BUILD_OPTIONS> och B<DEB_BUILD_MAINT_OPTIONS> modifierarna ”B<+>” och ”B<->”. Till exempel, för att aktivera B<hardening>-funktionen ”pie” och inaktivera funktionen ”fortify” genom att ange detta i B<debian/rules>:
+Feature areas are currently vendor specific, and the ones described below are only recognized on Debian and derivatives.
- export DEB_BUILD_MAINT_OPTIONS=hardening=+pie,-fortify
+Each area feature can be enabled and disabled in the B<DEB_BUILD_OPTIONS> and B<DEB_BUILD_MAINT_OPTIONS> environment variable's area value with the ‘B<+>’ and ‘B<->’ modifier. Following the general syntax of these variables (described in L<dpkg-buildpackage(1)>), multiple feature areas can be specified separated by spaces, where each get feature specifiers as mandatory parameters after an equal sign (‘B<=>’). The feature specifiers are comma-separated and parsed from left to right, where the settings within the same feature specifier override previous ones, even if the feature specifiers are split across multiple space-separated feature area settings for the same area.
+
+For example, to enable the B<hardening> “pie” feature and disable the “fortify” feature you can do this in B<debian/rules>:
+
+ export DEB_BUILD_MAINT_OPTIONS = hardening=+pie,-fortify
Den speciella funktionen B<all> kan användas för att aktivera eller inaktivera alla områdesfunktioner samtidigt. Du kan till exempel inaktivera allt i området B<hardening> och endast aktivera ”format” och ”fortify” med:
- export DEB_BUILD_MAINT_OPTIONS=hardening=-all,+format,+fortify
+ export DEB_BUILD_MAINT_OPTIONS = hardening=-all,+format,+fortify
+
+Multiple feature areas can be set:
+
+ export DEB_BUILD_MAINT_OPTIONS = hardening=+pie abi=+lfs
+
+The override behavior applies as much to the B<all> special feature, as to specific features, which should allow for composition. Thus to enable “lfs” in the B<abi> area, and only “pie” and “fortify” in the B<hardening> area, but “format” only when CONDITION is defined, this could be done with:
+
+ export DEB_BUILD_MAINT_OPTIONS = hardening=-all,+pie,+format abi=+lfs
+ …
+ DEB_BUILD_MAINT_OPTIONS += hardening=+fortify
+ ifdef CONDITION
+ DEB_BUILD_MAINT_OPTIONS += hardening=-format
+ endif
=head2 abi
@@ -312,7 +329,11 @@ När funktionen är aktiverad kommer den överstyra värdet från samma funktion
=item B<time64>
-Den här inställningen (sedan dpkg 1.22.0; inaktiverad som förval) aktiverar stöd för 64-bitars time_t på 32-bitars-arkitekturer där deras ABI inte som förval inkluderar det, genom att lägga till B<-D_TIME_BITS=64> till B<CPPFLAGS>. Inställningen aktiverar automatiskt L<lfs>-funktionerna eftersom den behövs för att den ska fungera.
+This setting (since dpkg 1.22.0; enabled by default except for i386, hurd-i386 and kfreebsd-i386 since dpkg 1.22.5) enables 64-bit time_t support on 32-bit architectures where their ABI does not include it by default, by adding B<-D_TIME_BITS=64> to B<CPPFLAGS>. This setting automatically enables the B<lfs> feature from the B<abi> feature area, and the B<bug-implicit-func> feature from the B<qa> feature area as it requires them.
+
+If the setting is enabled explicitly then it gets enabled on all architectures including i386 but not hurd-i386 nor kfreebsd-i386 (where the kernel does not have time64 interfaces), ignoring the binary backwards compatibility default.
+
+It is also enabled by default by gcc on the armel, armhf, hppa, m68k, mips, mipsel, powerpc and sh4 Debian architectures, where disabling the feature will add instead B<-U_LARGEFILE_SOURCE -U_FILE_OFFSET_BITS -U_TIME_BITS> to B<CPPFLAGS>.
=back
diff --git a/man/sv/dpkg-buildpackage.pod b/man/sv/dpkg-buildpackage.pod
index cab0f7c..8834116 100644
--- a/man/sv/dpkg-buildpackage.pod
+++ b/man/sv/dpkg-buildpackage.pod
@@ -514,7 +514,7 @@ Används för att signera filerna B<.changes>, B<.buildinfo> och B<.dsc>-filerna
=item B<DEB_BUILD_OPTIONS>
-Om satt, innehåller en blankstegsavdelad lista med flaggor som påverkar beteendet för några dpkg-verktyg som används i paketbyggandet, och kan påverka paketbyggprocessen om koden i F<debian/rules> stöder dem.
+If set, it will contain a space-separated list of options that affect the behavior of some dpkg tools involved in package building, and might affect the package build process if the code in F<debian/rules> honors them. These options can have parameters specified immediately after an equal sign (‘B<=>‘). For options that support multiple parameters, these will not be separated by spaces, as these are reserved to separate options.
Följande flaggor känns och stöds av dpkg-verktygen, andra flaggor som stöds av F<debian/rules> kan anges av distributionsspecifika policydokument.
@@ -540,6 +540,22 @@ Paketets F<debian/rules> bör se till att objekt inte får felsökningsinformati
B<dpkg-buildpackage> lägger till L<make(1)>-flaggan B<--no-print-directory> till miljövariabeln B<MAKEFLAGS>. Paketets F<debian/rules> bör minska pratsamheten, utan att bli helt tyst.
+=item B<hardening=>I<feature-spec>
+
+=item B<reproducible=>I<feature-spec>
+
+=item B<abi=>I<feature-spec>
+
+=item B<future=>I<feature-spec>
+
+=item B<qa=>I<feature-spec>
+
+=item B<optimize=>I<feature-spec>
+
+=item B<sanitize=>I<feature-spec>
+
+These are feature areas that control build flag features. See L<dpkg-buildflags(1)> for further details.
+
=back
=item B<DEB_BUILD_PROFILES>
diff --git a/man/sv/dpkg-parsechangelog.pod b/man/sv/dpkg-parsechangelog.pod
index 9479a4e..f463821 100644
--- a/man/sv/dpkg-parsechangelog.pod
+++ b/man/sv/dpkg-parsechangelog.pod
@@ -34,7 +34,7 @@ Anger ändringsloggfilen som information ska läsas från. Ett ”-” kan anvä
=item B<-F> I<ändringsloggformat>
-Anger format på ändringsloggen. Som standard läses formatet från en speciell rad nära slutet av ändringsloggen, om det misslyckas används formatet B<debian> som standard. Se även B<FORMAT PÅ ÄNDRINGSLOGGEN>.
+Specifies the format of the changelog. By default the format is read from a special line near the bottom of the changelog or failing that defaults to the B<debian> standard format. See also L</CHANGELOG FORMATS>.
=item B<-L> I<bibliotekskatalog>
diff --git a/man/sv/dpkg-shlibdeps.pod b/man/sv/dpkg-shlibdeps.pod
index 67c89b7..47305b3 100644
--- a/man/sv/dpkg-shlibdeps.pod
+++ b/man/sv/dpkg-shlibdeps.pod
@@ -50,7 +50,7 @@ Paketlokal överstyrande beroendeinformation för delade bibliotek. Filerna befi
B<dpkg-shlibs> kommer ihåg den (största) minimala version som behövs av varje bibliotek när den söker genom de symboler som används av alla binärfilerna. När proceduren är avslutad kan den visa det minsta beroende som behövs av alla bibliotek som används (så tillvida informationen i I<symbols>-filerna är korrekt).
-Som en säkerhetsåtgärd kan en symbols-fil innehålla metainformationsfältet I<Build-Depends-Package>, varpå B<dpkg-shlibdeps> hämtar vilken minsta version som behövs för paketet ur B<Build-Depends>-fältet och använder denna version om den är högre än den minsta version som beräknats genom att söka genom symbolerna.
+As a safe-guard measure, a symbols file can provide a B<Build-Depends-Package> or B<Build-Depends-Packages> meta-information field and B<dpkg-shlibdeps> will extract the minimal version required by the corresponding package in the B<Build-Depends> field and use this version if it's higher than the minimal version computed by scanning symbols.
=head2 Shlibs-filer