summaryrefslogtreecommitdiffstats
path: root/scripts/mk/buildtools.mk
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/mk/buildtools.mk')
-rw-r--r--scripts/mk/buildtools.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/scripts/mk/buildtools.mk b/scripts/mk/buildtools.mk
index 1f63bee..def15c1 100644
--- a/scripts/mk/buildtools.mk
+++ b/scripts/mk/buildtools.mk
@@ -28,7 +28,9 @@
ifndef dpkg_buildtools_mk_included
dpkg_buildtools_mk_included = yes
-dpkg_datadir ?= $(dir $(lastword $(MAKEFILE_LIST)))
+ifndef dpkg_datadir
+ dpkg_datadir := $(dir $(lastword $(MAKEFILE_LIST)))
+endif
include $(dpkg_datadir)/architecture.mk
# We set the TOOL_FOR_BUILD variables to the specified value, and the TOOL