summaryrefslogtreecommitdiffstats
path: root/tests/t-conflicts-replaces/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t-conflicts-replaces/Makefile')
-rw-r--r--tests/t-conflicts-replaces/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/tests/t-conflicts-replaces/Makefile b/tests/t-conflicts-replaces/Makefile
new file mode 100644
index 0000000..350a068
--- /dev/null
+++ b/tests/t-conflicts-replaces/Makefile
@@ -0,0 +1,33 @@
+TESTS_DEB := pkg-a pkg-b
+
+include ../Test.mk
+
+test-case:
+ # test if the conflicting package replaces on install
+ $(DPKG_INSTALL) pkg-a.deb
+ $(DPKG_INSTALL) pkg-b.deb
+ $(call pkg_is_installed,pkg-b)
+ $(call pkg_is_not_installed,pkg-a)
+ -$(DPKG_PURGE) pkg-a pkg-b
+
+ # test if the conflicting package replaces on install
+ $(DPKG_INSTALL) pkg-a.deb pkg-b.deb
+ $(call pkg_is_installed,pkg-b)
+ $(call pkg_is_not_installed,pkg-a)
+ -$(DPKG_PURGE) pkg-a pkg-b
+
+ # test if the conflicting package fails on install
+ $(DPKG_INSTALL) pkg-b.deb
+ ! $(DPKG_INSTALL) pkg-a.deb
+ $(call pkg_is_not_installed,pkg-a)
+ $(call pkg_is_installed,pkg-b)
+ -$(DPKG_PURGE) pkg-a pkg-b
+
+ # test if the conflicting package fails on install
+ ! $(DPKG_INSTALL) pkg-b.deb pkg-a.deb
+ $(call pkg_is_not_installed,pkg-a)
+ -$(DPKG_PURGE) pkg-a pkg-b
+
+test-clean:
+ -$(DPKG_PURGE) pkg-a pkg-b
+