summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-03 13:55:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-03 13:55:43 +0000
commit0c0177f5cd57d7c736ec719cce34e754b47fda5a (patch)
tree9e54abadde506bc9bb6aeda4e19829573c7c7edb /debian/rules
parentAdding debian version 060+5-2~exp1. (diff)
downloaddracut-0c0177f5cd57d7c736ec719cce34e754b47fda5a.tar.xz
dracut-0c0177f5cd57d7c736ec719cce34e754b47fda5a.zip
Adding debian version 060+5-7.debian/060+5-7
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 7 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index bce1c66..b6f1f77 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,11 +9,13 @@ DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
export DRACUT_MAIN_VERSION=$(DEB_VERSION_UPSTREAM_REVISION)
export DRACUT_FULL_VERSION=$(DEB_VERSION)
+deb_systemdsystemunitdir = $(shell pkg-config --variable=systemdsystemunitdir systemd | sed s,^/,,)
+
%:
dh $@
override_dh_auto_configure:
- dh_auto_configure -- --systemdsystemunitdir=/lib/systemd/system --libdir=/usr/lib
+ dh_auto_configure -- --systemdsystemunitdir=/$(deb_systemdsystemunitdir) --libdir=/usr/lib
$(SHELL) debian/fix-revdate
mv dracut-version.sh dracut-version.sh.orig
echo '#!/bin/sh' > dracut-version.sh
@@ -40,6 +42,10 @@ endif
override_dh_auto_test:
+override_dh_install:
+ dh_install
+ dh_install -pdracut-core $(deb_systemdsystemunitdir)
+
override_dh_clean:
if test -e dracut-version.sh.orig ; then \
mv -f dracut-version.sh.orig dracut-version.sh ;\