summaryrefslogtreecommitdiffstats
path: root/debian/patches/fix-test-running-tests-no-longer-requires-to-be-root.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/fix-test-running-tests-no-longer-requires-to-be-root.patch')
-rw-r--r--debian/patches/fix-test-running-tests-no-longer-requires-to-be-root.patch18
1 files changed, 13 insertions, 5 deletions
diff --git a/debian/patches/fix-test-running-tests-no-longer-requires-to-be-root.patch b/debian/patches/fix-test-running-tests-no-longer-requires-to-be-root.patch
index 0dc6e44..3055a51 100644
--- a/debian/patches/fix-test-running-tests-no-longer-requires-to-be-root.patch
+++ b/debian/patches/fix-test-running-tests-no-longer-requires-to-be-root.patch
@@ -10,9 +10,11 @@ Origin: upstream, https://github.com/dracutdevs/dracut/pull/2429
test/test-functions | 12 ------------
4 files changed, 5 insertions(+), 19 deletions(-)
+diff --git a/Makefile b/Makefile
+index 333cd68..10a8e63 100644
--- a/Makefile
+++ b/Makefile
-@@ -264,7 +264,6 @@
+@@ -264,7 +264,6 @@ endif
endif
check: all syncheck
@@ -20,9 +22,11 @@ Origin: upstream, https://github.com/dracutdevs/dracut/pull/2429
@$(MAKE) -C test check
testimage: all
+diff --git a/docs/HACKING.md b/docs/HACKING.md
+index 6a19434..2e3d614 100644
--- a/docs/HACKING.md
+++ b/docs/HACKING.md
-@@ -253,27 +253,27 @@
+@@ -253,27 +253,27 @@ For the testsuite to pass, you will have to install at least the software packag
mentioned in the `test/container` Dockerfiles.
```
@@ -55,6 +59,8 @@ Origin: upstream, https://github.com/dracutdevs/dracut/pull/2429
+$ make run
```
to run the test without doing the setup.
+diff --git a/test/Makefile b/test/Makefile
+index dfaa450..518e7d6 100644
--- a/test/Makefile
+++ b/test/Makefile
@@ -1,7 +1,6 @@
@@ -65,9 +71,11 @@ Origin: upstream, https://github.com/dracutdevs/dracut/pull/2429
@{ \
[ -d $@ ] || exit 0; \
[ -f $@/Makefile ] || exit 0; \
+diff --git a/test/test-functions b/test/test-functions
+index f76d930..f28e30a 100644
--- a/test/test-functions
+++ b/test/test-functions
-@@ -52,15 +52,6 @@
+@@ -52,15 +52,6 @@ COLOR_FAILURE='\033[0;31m'
COLOR_WARNING='\033[0;33m'
COLOR_NORMAL='\033[0;39m'
@@ -83,7 +91,7 @@ Origin: upstream, https://github.com/dracutdevs/dracut/pull/2429
# generate qemu arguments for named raw disks
#
# qemu_add_drive_args <index> <args> <filename> <id-name> [<bootindex>]
-@@ -122,13 +113,11 @@
+@@ -122,13 +113,11 @@ test_marker_check() {
while (($# > 0)); do
case $1 in
--run)
@@ -97,7 +105,7 @@ Origin: upstream, https://github.com/dracutdevs/dracut/pull/2429
echo "TEST SETUP: $TEST_DESCRIPTION"
test_check && test_setup
exit $?
-@@ -141,7 +130,6 @@
+@@ -141,7 +130,6 @@ while (($# > 0)); do
exit $?
;;
--all)