summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-21 05:00:01 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-21 05:00:01 +0000
commit0214f09645b817703e3c6d16064c2ed17cba33fd (patch)
treeb1e2b8c93a026eec48b8d3d8ac82e71b86ab5278 /debian/rules
parentMerging upstream version 1.47.1. (diff)
downloade2fsprogs-0214f09645b817703e3c6d16064c2ed17cba33fd.tar.xz
e2fsprogs-0214f09645b817703e3c6d16064c2ed17cba33fd.zip
Merging debian version 1.47.1-1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 17 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 24afbab..1d88157 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,6 +23,11 @@ ifneq ($(filter pkg.e2fsprogs.no-fuse2fs,$(DEB_BUILD_PROFILES)),)
SKIP_FUSE2FS=yes
endif
+ifneq (,$(filter-out parallel=1,$(filter parallel=%,$(DEB_BUILD_OPTIONS))))
+ NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+ JOBS = -j$(NUMJOBS)
+endif
+
COMERR_VERSION ?= $(shell grep ELF_VERSION lib/et/Makefile.in | cut '-d ' -f3)
SS_VERSION ?= $(shell grep ELF_VERSION lib/ss/Makefile.in | cut '-d ' -f3)
@@ -61,6 +66,11 @@ CC ?= $(DEB_HOST_GNU_TYPE)-gcc
COMMON_CONF_FLAGS += --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
endif
+# work around Debian Bug #1070042
+ifeq ($(DEB_HOST_ARCH),mips64el)
+COMMON_CONF_FLAGS += --without-libarchive
+endif
+
%:
dh $@ -B${stdbuilddir}
@@ -72,7 +82,7 @@ override_dh_auto_configure:
../../configure ${COMMON_CONF_FLAGS}
override_dh_auto_build:
- $(MAKE) -C ${stdbuilddir} V=1 all
+ $(MAKE) -C ${stdbuilddir} V=1 $(JOBS) all
ifeq (,$(filter pkg.e2fsprogs.no-static,$(DEB_BUILD_PROFILES)))
$(MAKE) -C ${stdbuilddir}/e2fsck V=1 e2fsck.static
endif
@@ -153,6 +163,11 @@ override_dh_installinfo:
dh_installinfo -pcomerr-dev ${stdbuilddir}/lib/et/com_err.info
dh_installinfo -plibext2fs-dev ${stdbuilddir}/doc/libext2fs.info
+ifneq ($(DEB_HOST_ARCH_OS), hurd)
+override_dh_installsystemd:
+ dh_installsystemd -p e2fsprogs --no-restart-after-upgrade --no-stop-on-upgrade e2scrub_all.timer e2scrub_reap.service
+endif
+
override_dh_makeshlibs:
for i in $(SYMBOL_LIBS); \
do \
@@ -184,7 +199,7 @@ override_dh_gencontrol:
override_dh_auto_test:
ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
- PRINT_FAILED=yes $(MAKE) -C ${stdbuilddir} V=1 check
+ PRINT_FAILED=yes $(MAKE) -C ${stdbuilddir} V=1 $(JOBS) check
endif
test_printenv: