summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:16:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 20:16:44 +0000
commit367f23a94b60c40f76716e2e50566b686baf36b8 (patch)
tree3b6280f7c05bee0df7f9109958a44bfbc54d7639 /configure.ac
parentInitial commit. (diff)
downloadexfatprogs-367f23a94b60c40f76716e2e50566b686baf36b8.tar.xz
exfatprogs-367f23a94b60c40f76716e2e50566b686baf36b8.zip
Adding upstream version 1.2.2.upstream/1.2.2upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 38 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..bc20774
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,38 @@
+AC_PREREQ([2.68])
+
+m4_define([exfat_progs_version], m4_esyscmd_s(
+ grep "define EXFAT_PROGS_VERSION " include/version.h | \
+ awk '{print $3}' | sed 's/\"//g'))
+
+AC_INIT([exfatprogs],
+ exfat_progs_version,
+ [linkinjeon@kernel.org],
+ [exfatprogs],
+ [https://github.com/exfatprogs/exfatprogs])
+
+AC_CONFIG_SRCDIR([config.h.in])
+AC_CONFIG_HEADER([config.h])
+AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([foreign tar-pax dist-xz subdir-objects])
+
+AC_LANG([C])
+AC_PROG_CC
+AC_PROG_CC_STDC
+AM_SILENT_RULES([yes])
+AC_PROG_LIBTOOL
+AC_SYS_LARGEFILE
+AC_C_BIGENDIAN
+
+AC_CONFIG_FILES([
+ Makefile
+ lib/Makefile
+ mkfs/Makefile
+ fsck/Makefile
+ tune/Makefile
+ label/Makefile
+ dump/Makefile
+ exfat2img/Makefile
+])
+
+AC_OUTPUT