summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
new file mode 100644
index 0000000..0fe7096
--- /dev/null
+++ b/lib/Makefile.am
@@ -0,0 +1,34 @@
+MAINTAINERCLEANFILES = Makefile.in
+
+TARGET = fencing.py fencing_snmp.py azure_fence.py
+
+if BUILD_XENAPILIB
+TARGET += XenAPI.py
+endif
+
+SRC = fencing.py.py fencing_snmp.py.py XenAPI.py.py azure_fence.py.py check_used_options.py
+
+XSL = fence2man.xsl fence2rng.xsl fence2wiki.xsl
+
+FASRNG = fence.rng.head fence.rng.tail metadata.rng
+
+EXTRA_DIST = $(SRC) $(XSL) $(FASRNG)
+
+fencelibdir = ${FENCEAGENTSLIBDIR}
+
+fencelib_DATA = $(TARGET)
+
+rngdir = ${CLUSTERDATA}/relaxng
+
+rng_DATA = $(XSL) $(FASRNG)
+
+azure_fence.py: fencing.py
+fencing_snmp.py: fencing.py
+check_used_options.py: fencing.py
+
+include $(top_srcdir)/make/fencebuild.mk
+
+xml-check: all
+xml-upload: all
+
+clean-man: