summaryrefslogtreecommitdiffstats
path: root/debian/dh
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:55:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:55:44 +0000
commit6d5b6d03595796fac6d0aec608e985aa620354ff (patch)
tree1093002d8d80a0755fe25a49419e1f812c26f171 /debian/dh
parentAdding upstream version 115.8.0esr. (diff)
downloadfirefox-esr-6d5b6d03595796fac6d0aec608e985aa620354ff.tar.xz
firefox-esr-6d5b6d03595796fac6d0aec608e985aa620354ff.zip
Adding debian version 115.8.0esr-1.debian/115.8.0esr-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/dh')
-rwxr-xr-xdebian/dh25
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/dh b/debian/dh
new file mode 100755
index 0000000000..5b43536dd4
--- /dev/null
+++ b/debian/dh
@@ -0,0 +1,25 @@
+#!/bin/sh
+
+# Wrapper around dh to enable parallelism in debian/rules if not already
+# enabled.
+
+case "$MAKEFLAGS" in
+*-j*)
+ # Already enabled, do nothing.
+ ;;
+*)
+ parallel=
+ for opt in "$DEB_BUILD_OPTIONS"; do
+ case "$opt" in
+ parallel=*)
+ parallel=${opt#parallel=}
+ ;;
+ esac
+ done
+ if [ -n "$parallel" ]; then
+ export MAKEFLAGS="-j$parallel${MAKEFLAGS:+ $MAKEFLAGS}"
+ fi
+ ;;
+esac
+
+exec dh "$@"