summaryrefslogtreecommitdiffstats
path: root/js/src/rust/shared
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:47:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:47:29 +0000
commit0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d (patch)
treea31f07c9bcca9d56ce61e9a1ffd30ef350d513aa /js/src/rust/shared
parentInitial commit. (diff)
downloadfirefox-esr-0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d.tar.xz
firefox-esr-0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d.zip
Adding upstream version 115.8.0esr.upstream/115.8.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'js/src/rust/shared')
-rw-r--r--js/src/rust/shared/Cargo.toml28
-rw-r--r--js/src/rust/shared/lib.rs23
2 files changed, 51 insertions, 0 deletions
diff --git a/js/src/rust/shared/Cargo.toml b/js/src/rust/shared/Cargo.toml
new file mode 100644
index 0000000000..175d967af3
--- /dev/null
+++ b/js/src/rust/shared/Cargo.toml
@@ -0,0 +1,28 @@
+[package]
+name = "jsrust_shared"
+version = "0.1.0"
+authors = ["The Spidermonkey developers"]
+license = "MPL-2.0"
+
+[lib]
+crate-type = ["rlib"]
+name = "jsrust_shared"
+path = "lib.rs"
+
+[dependencies]
+encoding_c = "0.9.5"
+encoding_c_mem = "0.2.4"
+smoosh = { path = "../../frontend/smoosh", optional = true }
+mozilla-central-workspace-hack = { path = "../../../../build/workspace-hack" }
+mozglue-static = { path = "../../../../mozglue/static/rust" }
+gluesmith = { path = "../../fuzz-tests/gluesmith", optional = true }
+
+[features]
+simd-accel = ['encoding_c/simd-accel']
+
+# Uncomment this to enable perf support in release mode.
+#[profile.release]
+#debug = true
+
+[package.metadata.cargo-udeps.ignore]
+normal = ["mozilla-central-workspace-hack"]
diff --git a/js/src/rust/shared/lib.rs b/js/src/rust/shared/lib.rs
new file mode 100644
index 0000000000..eb85586835
--- /dev/null
+++ b/js/src/rust/shared/lib.rs
@@ -0,0 +1,23 @@
+/* Copyright 2018 Mozilla Foundation
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+extern crate encoding_c;
+extern crate encoding_c_mem;
+extern crate mozglue_static;
+
+#[cfg(feature = "smoosh")]
+extern crate smoosh;
+
+#[cfg(feature = "gluesmith")]
+extern crate gluesmith;