summaryrefslogtreecommitdiffstats
path: root/media/libopus/Makefile.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:47:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:47:29 +0000
commit0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d (patch)
treea31f07c9bcca9d56ce61e9a1ffd30ef350d513aa /media/libopus/Makefile.in
parentInitial commit. (diff)
downloadfirefox-esr-0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d.tar.xz
firefox-esr-0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d.zip
Adding upstream version 115.8.0esr.upstream/115.8.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'media/libopus/Makefile.in')
-rw-r--r--media/libopus/Makefile.in21
1 files changed, 21 insertions, 0 deletions
diff --git a/media/libopus/Makefile.in b/media/libopus/Makefile.in
new file mode 100644
index 0000000000..4fa77570f6
--- /dev/null
+++ b/media/libopus/Makefile.in
@@ -0,0 +1,21 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+include $(topsrcdir)/config/rules.mk
+
+ifdef GNU_AS
+ifeq ($(CPU_ARCH),arm)
+
+celt_pitch_xcorr_arm-gnu.s: celt/arm/armopts-gnu.S
+
+# armopts needs a specific rule, because arm2gnu.pl will always add the .S
+# suffix when translating the files that include it.
+celt/arm/armopts-gnu.S: $(srcdir)/celt/arm/armopts.s $(call mkdir_deps,celt/arm) $(GLOBAL_DEPS)
+ $(PERL) $(srcdir)/celt/arm/arm2gnu.pl < $< > $@
+# For all others, we can use an implicit rule
+%-gnu.s: $(srcdir)/celt/arm/%.s $(GLOBAL_DEPS)
+ $(PERL) $(srcdir)/celt/arm/arm2gnu.pl < $< > $@
+
+endif
+endif