summaryrefslogtreecommitdiffstats
path: root/third_party/rust/audio_thread_priority/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:47:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:47:29 +0000
commit0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d (patch)
treea31f07c9bcca9d56ce61e9a1ffd30ef350d513aa /third_party/rust/audio_thread_priority/Makefile
parentInitial commit. (diff)
downloadfirefox-esr-0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d.tar.xz
firefox-esr-0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d.zip
Adding upstream version 115.8.0esr.upstream/115.8.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/audio_thread_priority/Makefile')
-rw-r--r--third_party/rust/audio_thread_priority/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/third_party/rust/audio_thread_priority/Makefile b/third_party/rust/audio_thread_priority/Makefile
new file mode 100644
index 0000000000..9a0e1c7af7
--- /dev/null
+++ b/third_party/rust/audio_thread_priority/Makefile
@@ -0,0 +1,8 @@
+all: target/debug/libaudio_thread_priority.a
+ g++ atp_test.cpp target/debug/libaudio_thread_priority.a -I. -lpthread -ldbus-1 -ldl -g -o atp_test
+
+check:
+ @./atp_test && echo "test passed" || echo "test failed"
+
+target/debug/libaudio_thread_priority.a:
+ cargo build