summaryrefslogtreecommitdiffstats
path: root/third_party/rust/goblin/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:47:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:47:29 +0000
commit0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d (patch)
treea31f07c9bcca9d56ce61e9a1ffd30ef350d513aa /third_party/rust/goblin/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d.tar.xz
firefox-esr-0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d.zip
Adding upstream version 115.8.0esr.upstream/115.8.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/goblin/Cargo.toml')
-rw-r--r--third_party/rust/goblin/Cargo.toml106
1 files changed, 106 insertions, 0 deletions
diff --git a/third_party/rust/goblin/Cargo.toml b/third_party/rust/goblin/Cargo.toml
new file mode 100644
index 0000000000..e557d907bf
--- /dev/null
+++ b/third_party/rust/goblin/Cargo.toml
@@ -0,0 +1,106 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.56.0"
+name = "goblin"
+version = "0.6.0"
+authors = [
+ "m4b <m4b.github.io@gmail.com>",
+ "seu <seu@panopticon.re>",
+ "Will Glynn <will@willglynn.com>",
+ "Philip Craig <philipjcraig@gmail.com>",
+ "Lzu Tao <taolzu@gmail.com>",
+]
+include = [
+ "src",
+ "CHANGELOG.md",
+ "Cargo.toml",
+ "LICENSE",
+ "README.md",
+]
+description = "An impish, cross-platform, ELF, Mach-o, and PE binary parsing and loading crate"
+documentation = "https://docs.rs/goblin"
+readme = "README.md"
+keywords = [
+ "binary",
+ "elf",
+ "mach",
+ "pe",
+ "archive",
+]
+categories = [
+ "parsing",
+ "development-tools::debugging",
+]
+license = "MIT"
+repository = "https://github.com/m4b/goblin"
+resolver = "2"
+
+[dependencies.log]
+version = "0.4"
+optional = true
+default-features = false
+
+[dependencies.plain]
+version = "0.2.3"
+
+[dependencies.scroll]
+version = "0.11"
+default_features = false
+
+[features]
+alloc = [
+ "scroll/derive",
+ "log",
+]
+archive = ["alloc"]
+default = [
+ "std",
+ "elf32",
+ "elf64",
+ "mach32",
+ "mach64",
+ "pe32",
+ "pe64",
+ "archive",
+ "endian_fd",
+]
+elf32 = []
+elf64 = []
+endian_fd = ["alloc"]
+mach32 = [
+ "alloc",
+ "endian_fd",
+ "archive",
+]
+mach64 = [
+ "alloc",
+ "endian_fd",
+ "archive",
+]
+pe32 = [
+ "alloc",
+ "endian_fd",
+]
+pe64 = [
+ "alloc",
+ "endian_fd",
+]
+std = [
+ "alloc",
+ "scroll/std",
+]
+
+[badges.travis-ci]
+branch = "master"
+repository = "m4b/goblin"