summaryrefslogtreecommitdiffstats
path: root/third_party/rust/nix/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:47:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:47:29 +0000
commit0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d (patch)
treea31f07c9bcca9d56ce61e9a1ffd30ef350d513aa /third_party/rust/nix/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d.tar.xz
firefox-esr-0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d.zip
Adding upstream version 115.8.0esr.upstream/115.8.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/nix/Cargo.toml')
-rw-r--r--third_party/rust/nix/Cargo.toml185
1 files changed, 185 insertions, 0 deletions
diff --git a/third_party/rust/nix/Cargo.toml b/third_party/rust/nix/Cargo.toml
new file mode 100644
index 0000000000..0afc445c22
--- /dev/null
+++ b/third_party/rust/nix/Cargo.toml
@@ -0,0 +1,185 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.56"
+name = "nix"
+version = "0.26.2"
+authors = ["The nix-rust Project Developers"]
+include = [
+ "src/**/*",
+ "test/**/*",
+ "LICENSE",
+ "README.md",
+ "CHANGELOG.md",
+]
+description = "Rust friendly bindings to *nix APIs"
+readme = "README.md"
+categories = ["os::unix-apis"]
+license = "MIT"
+repository = "https://github.com/nix-rust/nix"
+
+[package.metadata.docs.rs]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+targets = [
+ "x86_64-unknown-linux-gnu",
+ "aarch64-linux-android",
+ "x86_64-apple-darwin",
+ "aarch64-apple-ios",
+ "x86_64-unknown-freebsd",
+ "x86_64-unknown-openbsd",
+ "x86_64-unknown-netbsd",
+ "x86_64-unknown-dragonfly",
+ "x86_64-fuchsia",
+ "x86_64-unknown-redox",
+ "x86_64-unknown-illumos",
+]
+
+[[test]]
+name = "test"
+path = "test/test.rs"
+
+[[test]]
+name = "test-aio-drop"
+path = "test/sys/test_aio_drop.rs"
+
+[[test]]
+name = "test-clearenv"
+path = "test/test_clearenv.rs"
+
+[[test]]
+name = "test-mount"
+path = "test/test_mount.rs"
+harness = false
+
+[[test]]
+name = "test-ptymaster-drop"
+path = "test/test_ptymaster_drop.rs"
+
+[dependencies.bitflags]
+version = "1.1"
+
+[dependencies.cfg-if]
+version = "1.0"
+
+[dependencies.libc]
+version = "0.2.137"
+features = ["extra_traits"]
+
+[dependencies.pin-utils]
+version = "0.1.0"
+optional = true
+
+[dependencies.static_assertions]
+version = "1"
+
+[dev-dependencies.assert-impl]
+version = "0.1"
+
+[dev-dependencies.lazy_static]
+version = "1.4"
+
+[dev-dependencies.parking_lot]
+version = "0.12"
+
+[dev-dependencies.rand]
+version = "0.8"
+
+[dev-dependencies.semver]
+version = "1.0.7"
+
+[dev-dependencies.tempfile]
+version = "3.3.0"
+
+[features]
+acct = []
+aio = ["pin-utils"]
+default = [
+ "acct",
+ "aio",
+ "dir",
+ "env",
+ "event",
+ "feature",
+ "fs",
+ "hostname",
+ "inotify",
+ "ioctl",
+ "kmod",
+ "mman",
+ "mount",
+ "mqueue",
+ "net",
+ "personality",
+ "poll",
+ "process",
+ "pthread",
+ "ptrace",
+ "quota",
+ "reboot",
+ "resource",
+ "sched",
+ "signal",
+ "socket",
+ "term",
+ "time",
+ "ucontext",
+ "uio",
+ "user",
+ "zerocopy",
+]
+dir = ["fs"]
+env = []
+event = []
+feature = []
+fs = []
+hostname = []
+inotify = []
+ioctl = []
+kmod = []
+mman = []
+mount = ["uio"]
+mqueue = ["fs"]
+net = ["socket"]
+personality = []
+poll = []
+process = []
+pthread = []
+ptrace = ["process"]
+quota = []
+reboot = []
+resource = []
+sched = ["process"]
+signal = ["process"]
+socket = ["memoffset"]
+term = []
+time = []
+ucontext = ["signal"]
+uio = []
+user = ["feature"]
+zerocopy = [
+ "fs",
+ "uio",
+]
+
+[target."cfg(any(target_os = \"android\", target_os = \"linux\"))".dev-dependencies.caps]
+version = "0.5.3"
+
+[target."cfg(not(target_os = \"redox\"))".dependencies.memoffset]
+version = "0.7"
+optional = true
+
+[target."cfg(target_os = \"freebsd\")".dev-dependencies.sysctl]
+version = "0.4"