summaryrefslogtreecommitdiffstats
path: root/third_party/rust/typed-arena-nomut/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:47:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:47:29 +0000
commit0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d (patch)
treea31f07c9bcca9d56ce61e9a1ffd30ef350d513aa /third_party/rust/typed-arena-nomut/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d.tar.xz
firefox-esr-0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d.zip
Adding upstream version 115.8.0esr.upstream/115.8.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/typed-arena-nomut/Cargo.toml')
-rw-r--r--third_party/rust/typed-arena-nomut/Cargo.toml39
1 files changed, 39 insertions, 0 deletions
diff --git a/third_party/rust/typed-arena-nomut/Cargo.toml b/third_party/rust/typed-arena-nomut/Cargo.toml
new file mode 100644
index 0000000000..1558941d12
--- /dev/null
+++ b/third_party/rust/typed-arena-nomut/Cargo.toml
@@ -0,0 +1,39 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "typed-arena-nomut"
+version = "0.1.0"
+authors = ["Simon Sapin <simon.sapin@exyr.org>", "Nick Fitzgerald <fitzgen@gmail.com>"]
+description = "The arena, a fast but limited type of allocator"
+documentation = "https://docs.rs/typed-arena"
+readme = "./README.md"
+keywords = ["arena"]
+categories = ["memory-management", "no-std"]
+license = "MIT"
+repository = "https://github.com/jrmuizel/typed-arena-nomut"
+[profile.bench]
+debug = true
+
+[lib]
+name = "typed_arena_nomut"
+path = "src/lib.rs"
+
+[[bench]]
+name = "benches"
+path = "benches/benches.rs"
+harness = false
+[dev-dependencies.criterion]
+version = "0.3.4"
+
+[features]
+default = ["std"]
+std = []