summaryrefslogtreecommitdiffstats
path: root/third_party/rust/wasmparser/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:47:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:47:29 +0000
commit0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d (patch)
treea31f07c9bcca9d56ce61e9a1ffd30ef350d513aa /third_party/rust/wasmparser/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d.tar.xz
firefox-esr-0ebf5bdf043a27fd3dfb7f92e0cb63d88954c44d.zip
Adding upstream version 115.8.0esr.upstream/115.8.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/wasmparser/Cargo.toml')
-rw-r--r--third_party/rust/wasmparser/Cargo.toml54
1 files changed, 54 insertions, 0 deletions
diff --git a/third_party/rust/wasmparser/Cargo.toml b/third_party/rust/wasmparser/Cargo.toml
new file mode 100644
index 0000000000..9717ba19f8
--- /dev/null
+++ b/third_party/rust/wasmparser/Cargo.toml
@@ -0,0 +1,54 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "wasmparser"
+version = "0.102.0"
+authors = ["Yury Delendik <ydelendik@mozilla.com>"]
+exclude = ["benches/*.wasm"]
+description = """
+A simple event-driven library for parsing WebAssembly binary files.
+"""
+homepage = "https://github.com/bytecodealliance/wasm-tools/tree/main/crates/wasmparser"
+readme = "README.md"
+keywords = [
+ "parser",
+ "WebAssembly",
+ "wasm",
+]
+license = "Apache-2.0 WITH LLVM-exception"
+repository = "https://github.com/bytecodealliance/wasm-tools/tree/main/crates/wasmparser"
+
+[[bench]]
+name = "benchmark"
+harness = false
+
+[dependencies.indexmap]
+version = "1.9.1"
+
+[dependencies.url]
+version = "2.0.0"
+
+[dev-dependencies.anyhow]
+version = "1.0.58"
+
+[dev-dependencies.criterion]
+version = "0.3.3"
+
+[dev-dependencies.once_cell]
+version = "1.13.0"
+
+[dev-dependencies.rayon]
+version = "1.3"
+
+[dev-dependencies.wasm-encoder]
+version = "0.25.0"