summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/css/cssom/stylesheet-replacedata-dynamic.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/css/cssom/stylesheet-replacedata-dynamic.html')
-rw-r--r--testing/web-platform/tests/css/cssom/stylesheet-replacedata-dynamic.html12
1 files changed, 12 insertions, 0 deletions
diff --git a/testing/web-platform/tests/css/cssom/stylesheet-replacedata-dynamic.html b/testing/web-platform/tests/css/cssom/stylesheet-replacedata-dynamic.html
new file mode 100644
index 0000000000..3ee5937c95
--- /dev/null
+++ b/testing/web-platform/tests/css/cssom/stylesheet-replacedata-dynamic.html
@@ -0,0 +1,12 @@
+<!doctype html>
+<title>(Test #1) CSS Test: Dynamic changes to the stylesheet contents using replaceData are reflected</title>
+<link rel="match" href="stylesheet-replacedata-dynamic-ref.html">
+<link rel="author" title="Emilio Cobos Álvarez" href="mailto:emilio@mozilla.com">
+<link rel="author" title="Cheng You Bai" href="mailto:cyb.ai.815@gmail.com">
+<link rel="help" href="https://dom.spec.whatwg.org/#dom-characterdata-replacedata">
+<style>.fail { color: green }</style>
+<div class="pass">Should be green</div>
+<script>
+ document.body.offsetTop;
+ document.querySelector('style').firstChild.replaceData(1, 4, "pass");
+</script> \ No newline at end of file