summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/navigation-timing/dom-interactive-image-document.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/navigation-timing/dom-interactive-image-document.html')
-rw-r--r--testing/web-platform/tests/navigation-timing/dom-interactive-image-document.html25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/web-platform/tests/navigation-timing/dom-interactive-image-document.html b/testing/web-platform/tests/navigation-timing/dom-interactive-image-document.html
new file mode 100644
index 0000000000..36742f0eff
--- /dev/null
+++ b/testing/web-platform/tests/navigation-timing/dom-interactive-image-document.html
@@ -0,0 +1,25 @@
+<!DOCTYPE html>
+<html>
+ <head>
+ <meta charset="utf-8" />
+ <title>Test domInteractive on image document.</title>
+ <link rel="author" title="Google" href="http://www.google.com/" />
+ <link rel="help" href="https://html.spec.whatwg.org/multipage/browsing-the-web.html#read-media"/>
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ </head>
+ <script>
+ const t = async_test("Test domInteractive on image document");
+ function frameLoaded() {
+ const timing = document.querySelector("iframe").contentWindow.performance.timing;
+ assert_greater_than(timing.domInteractive, 0,
+ "Expect domInteractive to be positive value.");
+ t.done();
+ }
+ </script>
+ <body>
+ <h1>Description</h1>
+ <p>This tests that a image document has positive-value domInteractive.</p>
+ <iframe src="../images/smiley.png" onload="frameLoaded()"></iframe>
+ </body>
+</html> \ No newline at end of file