summaryrefslogtreecommitdiffstats
path: root/third_party/function2/Findfunction2.cmake
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/function2/Findfunction2.cmake')
-rw-r--r--third_party/function2/Findfunction2.cmake10
1 files changed, 10 insertions, 0 deletions
diff --git a/third_party/function2/Findfunction2.cmake b/third_party/function2/Findfunction2.cmake
new file mode 100644
index 0000000000..ca1fc3e41f
--- /dev/null
+++ b/third_party/function2/Findfunction2.cmake
@@ -0,0 +1,10 @@
+# Makes it possible to find function2 through find_package(function2 REQUIRED)
+# when this source directory was added to the CMake module path.
+# For instance it could be done through adding this to the CMakeLists.txt
+# file in the parent directory:
+# ```cmake
+# list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_LIST_DIR}/function2")
+# ```
+
+set(FU2_IS_FIND_INCLUDED ON)
+include("${CMAKE_CURRENT_LIST_DIR}/CMakeLists.txt")