summaryrefslogtreecommitdiffstats
path: root/third_party/rust/ash/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/ash/Cargo.toml')
-rw-r--r--third_party/rust/ash/Cargo.toml53
1 files changed, 53 insertions, 0 deletions
diff --git a/third_party/rust/ash/Cargo.toml b/third_party/rust/ash/Cargo.toml
new file mode 100644
index 0000000000..429cbf7b24
--- /dev/null
+++ b/third_party/rust/ash/Cargo.toml
@@ -0,0 +1,53 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.59.0"
+name = "ash"
+version = "0.37.2+1.3.238"
+authors = [
+ "Maik Klein <maikklein@googlemail.com>",
+ "Benjamin Saunders <ben.e.saunders@gmail.com>",
+ "Marijn Suijten <marijn@traverseresearch.nl>",
+]
+description = "Vulkan bindings for Rust"
+documentation = "https://docs.rs/ash"
+readme = "README.md"
+keywords = [
+ "vulkan",
+ "graphic",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/MaikKlein/ash"
+
+[package.metadata.release]
+no-dev-version = true
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.libloading]
+version = "0.7"
+optional = true
+
+[features]
+debug = []
+default = [
+ "loaded",
+ "debug",
+]
+linked = []
+loaded = ["libloading"]