summaryrefslogtreecommitdiffstats
path: root/third_party/rust/darling_core/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/darling_core/Cargo.toml')
-rw-r--r--third_party/rust/darling_core/Cargo.toml49
1 files changed, 49 insertions, 0 deletions
diff --git a/third_party/rust/darling_core/Cargo.toml b/third_party/rust/darling_core/Cargo.toml
new file mode 100644
index 0000000000..9e5b5365d5
--- /dev/null
+++ b/third_party/rust/darling_core/Cargo.toml
@@ -0,0 +1,49 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "darling_core"
+version = "0.14.3"
+authors = ["Ted Driggs <ted.driggs@outlook.com>"]
+description = """
+Helper crate for proc-macro library for reading attributes into structs when
+implementing custom derives. Use https://crates.io/crates/darling in your code.
+"""
+license = "MIT"
+repository = "https://github.com/TedDriggs/darling"
+
+[dependencies.fnv]
+version = "1.0.7"
+
+[dependencies.ident_case]
+version = "1.0.1"
+
+[dependencies.proc-macro2]
+version = "1.0.37"
+
+[dependencies.quote]
+version = "1.0.18"
+
+[dependencies.strsim]
+version = "0.10.0"
+optional = true
+
+[dependencies.syn]
+version = "1.0.91"
+features = [
+ "full",
+ "extra-traits",
+]
+
+[features]
+diagnostics = []
+suggestions = ["strsim"]