summaryrefslogtreecommitdiffstats
path: root/third_party/rust/fastrand/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/fastrand/Cargo.toml')
-rw-r--r--third_party/rust/fastrand/Cargo.toml53
1 files changed, 53 insertions, 0 deletions
diff --git a/third_party/rust/fastrand/Cargo.toml b/third_party/rust/fastrand/Cargo.toml
new file mode 100644
index 0000000000..7cc602f171
--- /dev/null
+++ b/third_party/rust/fastrand/Cargo.toml
@@ -0,0 +1,53 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.34"
+name = "fastrand"
+version = "1.9.0"
+authors = ["Stjepan Glavina <stjepang@gmail.com>"]
+exclude = ["/.*"]
+description = "A simple and fast random number generator"
+readme = "README.md"
+keywords = [
+ "simple",
+ "fast",
+ "rand",
+ "random",
+ "wyrand",
+]
+categories = ["algorithms"]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/smol-rs/fastrand"
+
+[dev-dependencies.getrandom]
+version = "0.2"
+
+[dev-dependencies.rand]
+version = "0.8"
+
+[dev-dependencies.wyhash]
+version = "0.5"
+
+[target."cfg(all(target_arch = \"wasm32\", not(target_os = \"wasi\")))".dependencies.instant]
+version = "0.1"
+
+[target."cfg(all(target_arch = \"wasm32\", not(target_os = \"wasi\")))".dev-dependencies.getrandom]
+version = "0.2"
+features = ["js"]
+
+[target."cfg(all(target_arch = \"wasm32\", not(target_os = \"wasi\")))".dev-dependencies.instant]
+version = "0.1"
+features = ["wasm-bindgen"]
+
+[target."cfg(all(target_arch = \"wasm32\", not(target_os = \"wasi\")))".dev-dependencies.wasm-bindgen-test]
+version = "0.3"