summaryrefslogtreecommitdiffstats
path: root/third_party/rust/fluent-testing/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/fluent-testing/Cargo.toml')
-rw-r--r--third_party/rust/fluent-testing/Cargo.toml67
1 files changed, 67 insertions, 0 deletions
diff --git a/third_party/rust/fluent-testing/Cargo.toml b/third_party/rust/fluent-testing/Cargo.toml
new file mode 100644
index 0000000000..0cb37eb311
--- /dev/null
+++ b/third_party/rust/fluent-testing/Cargo.toml
@@ -0,0 +1,67 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "fluent-testing"
+version = "0.0.3"
+authors = [
+ "Zibi Braniecki <zibi@braniecki.net>",
+ "Erik Nordin <enordin@mozilla.com>",
+]
+include = [
+ "src/**/*",
+ "resources/**/*",
+ "Cargo.toml",
+ "README.md",
+ "LICENSE-APACHE",
+ "LICENSE-MIT",
+]
+description = """
+A collection of mock scenarios for testing fluent-rs components.
+"""
+homepage = "https://www.projectfluent.org"
+readme = "README.md"
+keywords = [
+ "localization",
+ "l10n",
+ "i18n",
+ "intl",
+ "internationalization",
+]
+categories = [
+ "localization",
+ "internationalization",
+]
+license = "Apache-2.0/MIT"
+repository = "https://github.com/projectfluent/fluent-rs"
+resolver = "1"
+
+[dependencies.fluent-bundle]
+version = "0.15.2"
+
+[dependencies.fluent-fallback]
+version = "0.7.0"
+
+[dependencies.tokio]
+version = "1.0"
+features = [
+ "fs",
+ "rt-multi-thread",
+ "macros",
+ "io-util",
+]
+optional = true
+
+[features]
+async = ["tokio"]
+default = ["sync"]
+sync = []