summaryrefslogtreecommitdiffstats
path: root/third_party/rust/guid_win
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/guid_win')
-rw-r--r--third_party/rust/guid_win/.cargo-checksum.json1
-rw-r--r--third_party/rust/guid_win/Cargo.toml40
-rw-r--r--third_party/rust/guid_win/LICENSE-APACHE201
-rw-r--r--third_party/rust/guid_win/LICENSE-MIT19
-rw-r--r--third_party/rust/guid_win/src/lib.rs189
5 files changed, 450 insertions, 0 deletions
diff --git a/third_party/rust/guid_win/.cargo-checksum.json b/third_party/rust/guid_win/.cargo-checksum.json
new file mode 100644
index 0000000000..8d74f8dd1f
--- /dev/null
+++ b/third_party/rust/guid_win/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"bf6616aba7e85411a7b0287c7386b961903094a8f89bf1405c918cc6d4b01e60","LICENSE-APACHE":"b40930bbcf80744c86c46a12bc9da056641d722716c378f5659b9e555ef833e1","LICENSE-MIT":"b9b0616c8d5ca93cd2a9cce115a2a5a977b1d586b4983afa98a1ec287b9ac623","src/lib.rs":"0ce6cd46f69b40fa4153f54ef5040b733ea3be2a709f4badac3d4d6afe5a072b"},"package":"d87f4be87a557b98b4e4316f2009834f4448652938a950c1e8b33ae25f6f183b"} \ No newline at end of file
diff --git a/third_party/rust/guid_win/Cargo.toml b/third_party/rust/guid_win/Cargo.toml
new file mode 100644
index 0000000000..eb537d39a2
--- /dev/null
+++ b/third_party/rust/guid_win/Cargo.toml
@@ -0,0 +1,40 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "guid_win"
+version = "0.2.0"
+authors = ["Adam Gashlin <agashlin@mozilla.com>"]
+description = "Windows GUID/CLSID/IID string and binary serialization"
+keywords = ["windows", "com", "win32"]
+categories = ["api-bindings", "os::windows-apis"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/agashlin/guid_win"
+[package.metadata.docs.rs]
+default-target = "x86_64-pc-windows-msvc"
+[dependencies.comedy]
+version = "0.2.0"
+
+[dependencies.serde]
+version = "1.0.80"
+optional = true
+
+[dependencies.serde_derive]
+version = "1.0.80"
+optional = true
+
+[dependencies.winapi]
+version = "0.3.6"
+features = ["combaseapi", "guiddef"]
+
+[features]
+guid_serde = ["serde", "serde_derive"]
diff --git a/third_party/rust/guid_win/LICENSE-APACHE b/third_party/rust/guid_win/LICENSE-APACHE
new file mode 100644
index 0000000000..8dada3edaf
--- /dev/null
+++ b/third_party/rust/guid_win/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+ TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+ 1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+ 2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+ 3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+ 4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+ 5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+ 6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+ 7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+ 8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+ 9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+ END OF TERMS AND CONDITIONS
+
+ APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "{}"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+ Copyright {yyyy} {name of copyright owner}
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
diff --git a/third_party/rust/guid_win/LICENSE-MIT b/third_party/rust/guid_win/LICENSE-MIT
new file mode 100644
index 0000000000..f11a67cde6
--- /dev/null
+++ b/third_party/rust/guid_win/LICENSE-MIT
@@ -0,0 +1,19 @@
+Copyright (c) 2019 The guid_win Developers
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/third_party/rust/guid_win/src/lib.rs b/third_party/rust/guid_win/src/lib.rs
new file mode 100644
index 0000000000..157df8e57a
--- /dev/null
+++ b/third_party/rust/guid_win/src/lib.rs
@@ -0,0 +1,189 @@
+// Licensed under the Apache License, Version 2.0
+// <LICENSE-APACHE or http://www.apache.org/licenses/LICENSE-2.0> or the MIT license
+// <LICENSE-MIT or http://opensource.org/licenses/MIT>, at your option.
+// All files in the project carrying such notice may not be copied, modified, or distributed
+// except according to those terms.
+
+//! Windows GUID/CLSID/IID string and binary serialization
+//!
+//! [`Guid`](struct.Guid.html) transparently wraps
+//! [`GUID`](https://msdn.microsoft.com/en-us/library/windows/desktop/aa373931(v=vs.85).aspx).
+//!
+//! Implements `Display` and `FromStr` string conversion, also `Hash` and `Eq`.
+//!
+//! Curly braces (`{}`) are optional for `FromStr`.
+//!
+//! # serde #
+//!
+//! Use the `guid_serde` feature to derive `Serialize` and `Deserialize`, you can then
+//! derive them for structs containing `GUID` like so:
+//!
+//! ```
+//! # fn main() {}
+//! #
+//! # #[cfg(feature = "guid_serde")]
+//! # extern crate serde_derive;
+//! # extern crate winapi;
+//! #
+//! # #[cfg(feature = "guid_serde")]
+//! # mod test {
+//! use guid_win::GUIDSerde;
+//! use serde_derive::{Deserialize, Serialize};
+//! use winapi::shared::guiddef::GUID;
+//!
+//! #[derive(Serialize, Deserialize)]
+//! struct SerdeTest {
+//! #[serde(with = "GUIDSerde")]
+//! guid: GUID,
+//! }
+//! # }
+//! ```
+
+extern crate comedy;
+#[cfg(feature = "guid_serde")]
+extern crate serde;
+#[cfg(feature = "guid_serde")]
+extern crate serde_derive;
+extern crate winapi;
+
+use std::ffi::{OsStr, OsString};
+use std::fmt::{Debug, Display, Error, Formatter, Result};
+use std::hash::{Hash, Hasher};
+use std::mem;
+use std::os::windows::ffi::{OsStrExt, OsStringExt};
+use std::result;
+use std::str::FromStr;
+
+use comedy::check_succeeded;
+
+use winapi::ctypes;
+use winapi::shared::guiddef::GUID;
+use winapi::um::combaseapi::{CLSIDFromString, StringFromGUID2};
+
+#[cfg(feature = "guid_serde")]
+use serde_derive::{Deserialize, Serialize};
+
+const GUID_STRING_CHARACTERS: usize = 38;
+
+#[cfg(feature = "guid_serde")]
+#[allow(non_snake_case)]
+#[derive(Serialize, Deserialize)]
+#[serde(remote = "GUID")]
+pub struct GUIDSerde {
+ Data1: ctypes::c_ulong,
+ Data2: ctypes::c_ushort,
+ Data3: ctypes::c_ushort,
+ Data4: [ctypes::c_uchar; 8],
+}
+
+/// Wraps `GUID`
+#[derive(Clone)]
+#[cfg_attr(feature = "guid_serde", derive(Serialize, Deserialize))]
+#[repr(transparent)]
+pub struct Guid(#[cfg_attr(feature = "guid_serde", serde(with = "GUIDSerde"))] pub GUID);
+
+impl PartialEq for Guid {
+ fn eq(&self, other: &Guid) -> bool {
+ self.0.Data1 == other.0.Data1
+ && self.0.Data2 == other.0.Data2
+ && self.0.Data3 == other.0.Data3
+ && self.0.Data4 == other.0.Data4
+ }
+}
+
+impl Eq for Guid {}
+
+impl Hash for Guid {
+ fn hash<H: Hasher>(&self, state: &mut H) {
+ self.0.Data1.hash(state);
+ self.0.Data2.hash(state);
+ self.0.Data3.hash(state);
+ self.0.Data4.hash(state);
+ }
+}
+
+impl Debug for Guid {
+ fn fmt(&self, f: &mut Formatter) -> Result {
+ write!(f, "{:?}", unsafe {
+ &mem::transmute::<Guid, [u8; mem::size_of::<Guid>()]>(self.clone())
+ })
+ }
+}
+
+/// Output a string via `StringFromGUID2()`
+impl Display for Guid {
+ fn fmt(&self, f: &mut Formatter) -> Result {
+ let mut s: [u16; GUID_STRING_CHARACTERS + 1] = unsafe { mem::uninitialized() };
+
+ let len = unsafe {
+ StringFromGUID2(
+ &(*self).0 as *const _ as *mut _,
+ s.as_mut_ptr(),
+ s.len() as ctypes::c_int,
+ )
+ };
+
+ if len <= 0 {
+ return Err(Error);
+ }
+ // len is number of characters, including the null terminator
+
+ let s = &s[..len as usize - 1];
+ // TODO: no reason to expect this to fail, maybe just unwrap()
+ if let Ok(s) = OsString::from_wide(&s).into_string() {
+ f.write_str(&s)
+ } else {
+ Err(Error)
+ }
+ }
+}
+
+/// Read from a string via `CLSIDFromString()`
+///
+/// Braces (`{}`) are added if missing.
+impl FromStr for Guid {
+ type Err = comedy::error::HResult;
+
+ fn from_str(s: &str) -> result::Result<Self, Self::Err> {
+ let mut guid = unsafe { mem::uninitialized() };
+
+ let braced;
+ let s = if s.starts_with('{') {
+ s
+ } else {
+ braced = format!("{{{}}}", s);
+ braced.as_str()
+ };
+ let s: Vec<_> = OsStr::new(s).encode_wide().chain(Some(0)).collect();
+
+ unsafe { check_succeeded!(CLSIDFromString(s.as_ptr(), &mut guid)) }?;
+
+ Ok(Guid(guid))
+ }
+}
+
+#[cfg(test)]
+mod test {
+ use super::Guid;
+ use std::str::FromStr;
+
+ #[test]
+ fn without_braces() {
+ let uuid = "F1BD1079-9F01-4BDC-8036-F09B70095066";
+ let guid = Guid::from_str(uuid).unwrap();
+ assert_eq!(format!("{}", guid), format!("{{{}}}", uuid));
+ }
+
+ #[test]
+ fn with_braces() {
+ let uuid = "{F1BD1079-9F01-4BDC-8036-F09B70095066}";
+ let guid = Guid::from_str(uuid).unwrap();
+ assert_eq!(format!("{}", guid), uuid);
+ }
+
+ #[test]
+ fn format_error() {
+ let uuid = "foo";
+ Guid::from_str(uuid).unwrap_err();
+ }
+}