summaryrefslogtreecommitdiffstats
path: root/third_party/rust/heck/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/heck/Cargo.toml')
-rw-r--r--third_party/rust/heck/Cargo.toml43
1 files changed, 43 insertions, 0 deletions
diff --git a/third_party/rust/heck/Cargo.toml b/third_party/rust/heck/Cargo.toml
new file mode 100644
index 0000000000..7990368600
--- /dev/null
+++ b/third_party/rust/heck/Cargo.toml
@@ -0,0 +1,43 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "heck"
+version = "0.4.1"
+authors = ["Without Boats <woboats@gmail.com>"]
+include = [
+ "src/**/*",
+ "LICENSE-*",
+ "README.md",
+ "CHANGELOG.md",
+]
+description = "heck is a case conversion library."
+homepage = "https://github.com/withoutboats/heck"
+documentation = "https://docs.rs/heck"
+readme = "README.md"
+keywords = [
+ "string",
+ "case",
+ "camel",
+ "snake",
+ "unicode",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/withoutboats/heck"
+
+[dependencies.unicode-segmentation]
+version = "1.2.0"
+optional = true
+
+[features]
+default = []
+unicode = ["unicode-segmentation"]