summaryrefslogtreecommitdiffstats
path: root/third_party/rust/libsqlite3-sys/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/libsqlite3-sys/Cargo.toml')
-rw-r--r--third_party/rust/libsqlite3-sys/Cargo.toml99
1 files changed, 99 insertions, 0 deletions
diff --git a/third_party/rust/libsqlite3-sys/Cargo.toml b/third_party/rust/libsqlite3-sys/Cargo.toml
new file mode 100644
index 0000000000..34130d77e5
--- /dev/null
+++ b/third_party/rust/libsqlite3-sys/Cargo.toml
@@ -0,0 +1,99 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "libsqlite3-sys"
+version = "0.25.2"
+authors = ["The rusqlite developers"]
+build = "build.rs"
+links = "sqlite3"
+description = "Native bindings to the libsqlite3 library"
+readme = "README.md"
+keywords = [
+ "sqlite",
+ "sqlcipher",
+ "ffi",
+]
+categories = ["external-ffi-bindings"]
+license = "MIT"
+repository = "https://github.com/rusqlite/rusqlite"
+
+[dependencies.openssl-sys]
+version = "0.9"
+optional = true
+
+[build-dependencies.bindgen]
+version = "0.60"
+features = ["runtime"]
+optional = true
+default-features = false
+
+[build-dependencies.cc]
+version = "1.0"
+optional = true
+
+[build-dependencies.pkg-config]
+version = "0.3.19"
+optional = true
+
+[build-dependencies.vcpkg]
+version = "0.2"
+optional = true
+
+[features]
+buildtime_bindgen = [
+ "bindgen",
+ "pkg-config",
+ "vcpkg",
+]
+bundled = [
+ "cc",
+ "bundled_bindings",
+]
+bundled-sqlcipher = ["bundled"]
+bundled-sqlcipher-vendored-openssl = [
+ "bundled-sqlcipher",
+ "openssl-sys/vendored",
+]
+bundled-windows = [
+ "cc",
+ "bundled_bindings",
+]
+bundled_bindings = []
+default = ["min_sqlite_version_3_6_8"]
+in_gecko = []
+min_sqlite_version_3_6_23 = [
+ "pkg-config",
+ "vcpkg",
+]
+min_sqlite_version_3_6_8 = [
+ "pkg-config",
+ "vcpkg",
+]
+min_sqlite_version_3_7_16 = [
+ "pkg-config",
+ "vcpkg",
+]
+min_sqlite_version_3_7_7 = [
+ "pkg-config",
+ "vcpkg",
+]
+preupdate_hook = ["buildtime_bindgen"]
+session = [
+ "preupdate_hook",
+ "buildtime_bindgen",
+]
+sqlcipher = []
+unlock_notify = []
+wasm32-wasi-vfs = []
+winsqlite3 = ["min_sqlite_version_3_7_16"]
+with-asan = []