summaryrefslogtreecommitdiffstats
path: root/third_party/rust/metal/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/metal/Makefile')
-rw-r--r--third_party/rust/metal/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/third_party/rust/metal/Makefile b/third_party/rust/metal/Makefile
new file mode 100644
index 0000000000..bc35876945
--- /dev/null
+++ b/third_party/rust/metal/Makefile
@@ -0,0 +1,12 @@
+
+compute:
+ xcrun -sdk macosx metal -c examples/compute/shaders.metal -o examples/compute/shaders.air
+ xcrun -sdk macosx metallib examples/compute/shaders.air -o examples/compute/shaders.metallib
+
+window:
+ xcrun -sdk macosx metal -c examples/window/shaders.metal -o examples/window/shaders.air
+ xcrun -sdk macosx metallib examples/window/shaders.air -o examples/window/shaders.metallib
+
+circle:
+ xcrun -sdk macosx metal -c examples/circle/shaders.metal -o examples/circle/shaders.air
+ xcrun -sdk macosx metallib examples/circle/shaders.air -o examples/circle/shaders.metallib