summaryrefslogtreecommitdiffstats
path: root/third_party/rust/minidump-common/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/minidump-common/Cargo.toml')
-rw-r--r--third_party/rust/minidump-common/Cargo.toml51
1 files changed, 51 insertions, 0 deletions
diff --git a/third_party/rust/minidump-common/Cargo.toml b/third_party/rust/minidump-common/Cargo.toml
new file mode 100644
index 0000000000..691a9b9b3e
--- /dev/null
+++ b/third_party/rust/minidump-common/Cargo.toml
@@ -0,0 +1,51 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "minidump-common"
+version = "0.15.2"
+authors = ["Ted Mielczarek <ted@mielczarek.org>"]
+description = "Some common types for working with minidump files."
+homepage = "https://github.com/rust-minidump/rust-minidump"
+readme = "README.md"
+license = "MIT"
+repository = "https://github.com/rust-minidump/rust-minidump"
+
+[dependencies.arbitrary]
+version = "1"
+features = ["derive"]
+optional = true
+
+[dependencies.bitflags]
+version = "1.3.2"
+
+[dependencies.debugid]
+version = "0.8.0"
+
+[dependencies.enum-primitive-derive]
+version = "0.2.2"
+
+[dependencies.num-traits]
+version = "0.2"
+
+[dependencies.range-map]
+version = "0.2"
+
+[dependencies.scroll]
+version = "0.11.0"
+features = ["derive"]
+
+[dependencies.smart-default]
+version = "0.6.0"
+
+[badges.travis-ci]
+repository = "rust-minidump/rust-minidump"