summaryrefslogtreecommitdiffstats
path: root/third_party/rust/smart-default/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/smart-default/Cargo.toml')
-rw-r--r--third_party/rust/smart-default/Cargo.toml34
1 files changed, 34 insertions, 0 deletions
diff --git a/third_party/rust/smart-default/Cargo.toml b/third_party/rust/smart-default/Cargo.toml
new file mode 100644
index 0000000000..80913a5e6c
--- /dev/null
+++ b/third_party/rust/smart-default/Cargo.toml
@@ -0,0 +1,34 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "smart-default"
+version = "0.6.0"
+authors = ["IdanArye <idanarye@gmail.com>"]
+description = "Rust custom-derive macro for Default with more control on the fields"
+documentation = "https://idanarye.github.io/rust-smart-default/"
+readme = "README.md"
+keywords = ["default"]
+license = "MIT"
+repository = "https://github.com/idanarye/rust-smart-default"
+
+[lib]
+proc-macro = true
+[dependencies.proc-macro2]
+version = "1"
+
+[dependencies.quote]
+version = "1"
+
+[dependencies.syn]
+version = "1"
+features = ["full"]