summaryrefslogtreecommitdiffstats
path: root/third_party/rust/tempfile/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/tempfile/Cargo.toml')
-rw-r--r--third_party/rust/tempfile/Cargo.toml43
1 files changed, 43 insertions, 0 deletions
diff --git a/third_party/rust/tempfile/Cargo.toml b/third_party/rust/tempfile/Cargo.toml
new file mode 100644
index 0000000000..253f8667b8
--- /dev/null
+++ b/third_party/rust/tempfile/Cargo.toml
@@ -0,0 +1,43 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "tempfile"
+version = "3.3.0"
+authors = ["Steven Allen <steven@stebalien.com>", "The Rust Project Developers", "Ashley Mannix <ashleymannix@live.com.au>", "Jason White <jasonaw0@gmail.com>"]
+exclude = ["/.travis.yml", "/appveyor.yml"]
+description = "A library for managing temporary files and directories."
+homepage = "http://stebalien.com/projects/tempfile-rs"
+documentation = "https://docs.rs/tempfile"
+keywords = ["tempfile", "tmpfile", "filesystem"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/Stebalien/tempfile"
+[dependencies.cfg-if]
+version = "1"
+
+[dependencies.fastrand]
+version = "1.6.0"
+
+[dependencies.remove_dir_all]
+version = "0.5"
+[dev-dependencies.doc-comment]
+version = "0.3"
+
+[features]
+nightly = []
+[target."cfg(any(unix, target_os = \"wasi\"))".dependencies.libc]
+version = "0.2.27"
+[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
+version = "0.2.9"
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3"
+features = ["fileapi", "handleapi", "winbase"]