summaryrefslogtreecommitdiffstats
path: root/toolkit/components/bitsdownload/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'toolkit/components/bitsdownload/Cargo.toml')
-rw-r--r--toolkit/components/bitsdownload/Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/toolkit/components/bitsdownload/Cargo.toml b/toolkit/components/bitsdownload/Cargo.toml
new file mode 100644
index 0000000000..7aff42359e
--- /dev/null
+++ b/toolkit/components/bitsdownload/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "bitsdownload"
+version = "0.1.0"
+authors = ["Kirk Steuber <bytesized@mozilla.com>"]
+license = "MPL-2.0"
+
+[dependencies]
+bits_client = { path = "./bits_client" }
+comedy = "0.2.0"
+crossbeam-utils = "0.8"
+libc = "0.2"
+log = "0.4"
+moz_task = { path = "../../../xpcom/rust/moz_task" }
+nserror = { path = "../../../xpcom/rust/nserror" }
+nsstring = { path = "../../../xpcom/rust/nsstring" }
+xpcom = { path = "../../../xpcom/rust/xpcom" }