summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml230
1 files changed, 230 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000000..bc31184750
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,230 @@
+[workspace]
+
+# These are the "root" crates, which we build and test as top-level targets.
+# Their transitive dependencies and dev-dependencies are included automatically
+# and do not need to be listed here. Their external dependencies are vendored
+# into `third_party/rust` by `mach vendor rust`.
+members = [
+ "js/src/frontend/smoosh",
+ "js/src/rust",
+ "netwerk/test/http3server",
+ "security/manager/ssl/builtins",
+ "security/manager/ssl/ipcclientcerts",
+ "security/manager/ssl/osclientcerts",
+ "testing/geckodriver",
+ "toolkit/components/uniffi-bindgen-gecko-js",
+ "toolkit/crashreporter/mozwer-rust",
+ "toolkit/crashreporter/rust_minidump_writer_linux",
+ "toolkit/library/gtest/rust",
+ "toolkit/library/rust/",
+]
+
+# Excluded crates may be built as dependencies, but won't be considered members
+# of the workspace and their dev-dependencies won't be included.
+exclude = [
+ # Exclude third-party code vendored into mozilla-central.
+ "servo",
+ "third_party/rust",
+
+ # Excluded because these crates have their own Cargo workspaces so they can't
+ # be included in the top-level one.
+ "gfx/wr",
+
+ # Excluded because they are used only as dependencies, not top-level targets,
+ # so we don't need to vendor their dev-dependencies.
+ "gfx/webrender_bindings",
+ "media/mp4parse-rust/mp4parse",
+ "media/mp4parse-rust/mp4parse_capi",
+ "xpcom/rust/gkrust_utils",
+ "tools/lint/test/files/clippy",
+ "tools/fuzzing/rust",
+ "dom/base/rust",
+ "dom/origin-trials/ffi",
+
+ # Excluded because we don't want to vendor their dependencies.
+ "intl/l10n/rust/l10nregistry-tests",
+]
+
+# Use the new dependency resolver to reduce some of the platform-specific dependencies.
+# This is required for 'third_party/rust/wgpu-hal'
+resolver = "2"
+
+[workspace.dependencies]
+# Shared across multiple UniFFI consumers.
+uniffi = "0.25.3"
+# Shared across multiple application-services consumers.
+rusqlite = "0.30.0"
+
+# Explicitly specify what our profiles use. The opt-level setting here is
+# a total fiction; see the setup of MOZ_RUST_DEFAULT_FLAGS for what the
+# opt-level setting will be as a result of various other configure flags.
+[profile.dev]
+opt-level = 1
+rpath = false
+lto = false
+debug-assertions = true
+panic = "abort"
+
+[profile.release]
+opt-level = 2
+rpath = false
+debug-assertions = false
+panic = "abort"
+
+# Optimize build dependencies, because bindgen and proc macros / style
+# compilation take more to run than to build otherwise.
+[profile.dev.build-override]
+opt-level = 1
+
+[profile.release.build-override]
+opt-level = 1
+
+# optimizing glsl more makes a big difference in swgl build times
+[profile.dev.package.glsl]
+opt-level = 2
+
+[profile.release.package.glsl]
+opt-level = 2
+
+[patch.crates-io]
+# The build system doesn't want those to be used, but they are pulled anyways (because
+# dependencies can't be disabled based on features), but remain unused. We ensure they
+# stay unused by overriding them with crates that contain enough to build the current
+# code and will fail the build in unwanted cases.
+cmake = { path = "build/rust/cmake" }
+vcpkg = { path = "build/rust/vcpkg" }
+
+# Helper crate for integration in the gecko build system.
+mozbuild = { path = "build/rust/mozbuild" }
+
+# Workspace hack
+mozilla-central-workspace-hack = { path = "build/workspace-hack" }
+
+# windows-targets replacement. It avoids the large dependencies of the original
+# crate, which we don't really need as we require MSVC anyways.
+windows-targets = { path = "build/rust/windows-targets" }
+windows-targets_0_48 = { package = "windows-targets", path = "build/rust/windows-targets-0.48" }
+
+# Patch windows-sys from 0.48.0 to 0.52.0
+windows-sys = { path = "build/rust/windows-sys" }
+
+# Patch windows to use a non-vendored local copy of the crate.
+windows = { path = "build/rust/windows" }
+
+# Dummy oslog replacement. It's only used by glean in code that is not actually used.
+oslog = { path = "build/rust/oslog" }
+
+# Override terminal_size with a dummy crate that returns a fixed 80x25 terminal size.
+terminal_size = { path = "build/rust/terminal_size" }
+
+# Patch bitflags 1.0 to 2.0
+bitflags = { path = "build/rust/bitflags" }
+
+# Patch memmap2 0.5.x and 0.8 to 0.9
+memmap2_0_5 = { package = "memmap2", path = "build/rust/memmap2-0.5" }
+memmap2 = { path = "build/rust/memmap2" }
+
+# Patch cfg-if 0.1 to 1.0
+cfg-if = { path = "build/rust/cfg-if" }
+
+# Patch redox_users to an empty crate
+redox_users = { path = "build/rust/redox_users" }
+
+# Patch redox_syscall to an empty crate
+redox_syscall = { path = "build/rust/redox_syscall" }
+
+# Override tinyvec with smallvec
+tinyvec = { path = "build/rust/tinyvec" }
+
+# Patch base64 0.13 to 0.21
+base64 = { path = "build/rust/base64" }
+
+# Patch wasi 0.10 to 0.11
+wasi = { path = "build/rust/wasi" }
+
+# tokio 0.29.0 includes an experimental "tracing" feature which requires
+# backtrace ^0.3.58 and the `tokio_unstable` flag. We don't use it, and nothing
+# else we do use requires backtrace, so dummy it out for now.
+backtrace = { path = "build/rust/backtrace" }
+
+# Patch bindgen 0.63 to 0.69
+bindgen_0_63 = { package = "bindgen", path = "build/rust/bindgen-0.63" }
+
+# Patch nix 0.26 to 0.27
+nix = { path = "build/rust/nix" }
+
+# Patch indexmap 2.0 to 1.0
+indexmap = { path = "build/rust/indexmap" }
+
+# Patch derive_more 0.99 to 1.0.0-beta
+derive_more = { path = "build/rust/derive_more" }
+
+# Patch autocfg to hide rustc output. Workaround for https://github.com/cuviper/autocfg/issues/30
+autocfg = { path = "third_party/rust/autocfg" }
+
+# Patch goblin 0.6.0 to 0.7.0 because uniffi crates still use the older version
+# and we want to avoid duplications
+goblin = { path = "build/rust/goblin" }
+
+# Patch memoffset from 0.8.0 to 0.9.0 since it's compatible and it avoids duplication
+memoffset = { path = "build/rust/memoffset" }
+
+# The following overrides point to dummy projects, as a temporary measure until this is resolved:
+# https://github.com/rust-lang/cargo/issues/6179
+js-sys = { path = "build/rust/dummy-web/js-sys" }
+wasm-bindgen = { path = "build/rust/dummy-web/wasm-bindgen" }
+web-sys = { path = "build/rust/dummy-web/web-sys" }
+
+# Overrides to allow easier use of common internal crates.
+moz_asserts = { path = "mozglue/static/rust/moz_asserts" }
+
+# Patch `rure` to disable building the cdylib and staticlib targets
+# Cargo has no way to disable building targets your dependencies provide which
+# you don't depend on, and linking the cdylib breaks during instrumentation
+# builds.
+# Workaround for https://github.com/rust-lang/cargo/issues/11232
+rure = { path = "third_party/rust/rure" }
+
+# To-be-published changes.
+cssparser = { git = "https://github.com/servo/rust-cssparser", rev = "aaa966d9d6ae70c4b8a62bb5e3a14c068bb7dff0" }
+cssparser-macros = { git = "https://github.com/servo/rust-cssparser", rev = "aaa966d9d6ae70c4b8a62bb5e3a14c068bb7dff0" }
+
+# Other overrides
+chardetng = { git = "https://github.com/hsivonen/chardetng", rev = "3484d3e3ebdc8931493aa5df4d7ee9360a90e76b" }
+chardetng_c = { git = "https://github.com/hsivonen/chardetng_c", rev = "ed8a4c6f900a90d4dbc1d64b856e61490a1c3570" }
+coremidi = { git = "https://github.com/chris-zen/coremidi.git", rev = "fc68464b5445caf111e41f643a2e69ccce0b4f83" }
+cose = { git = "https://github.com/franziskuskiefer/cose-rust", rev = "43c22248d136c8b38fe42ea709d08da6355cf04b" }
+firefox-on-glean = { path = "toolkit/components/glean/api" }
+icu_capi = { path = "intl/icu_capi" }
+icu_segmenter_data = { path = "intl/icu_segmenter_data" }
+libudev-sys = { path = "dom/webauthn/libudev-sys" }
+midir = { git = "https://github.com/mozilla/midir.git", rev = "85156e360a37d851734118104619f86bd18e94c6" }
+# warp 0.3.6 + https://github.com/seanmonstar/warp/pull/1069
+warp = { git = "https://github.com/seanmonstar/warp", rev = "9d081461ae1167eb321585ce424f4fef6cf0092b" }
+# Allow webrender to have a versioned dependency on the older crate on crates.io
+# in order to build standalone.
+malloc_size_of_derive = { path = "xpcom/rust/malloc_size_of_derive" }
+
+# application-services overrides to make updating them all simpler.
+interrupt-support = { git = "https://github.com/mozilla/application-services", rev = "5fc8ee2f0f6950e36d4096983757bd046d55df9f" }
+sql-support = { git = "https://github.com/mozilla/application-services", rev = "5fc8ee2f0f6950e36d4096983757bd046d55df9f" }
+suggest = { git = "https://github.com/mozilla/application-services", rev = "5fc8ee2f0f6950e36d4096983757bd046d55df9f" }
+sync15 = { git = "https://github.com/mozilla/application-services", rev = "5fc8ee2f0f6950e36d4096983757bd046d55df9f" }
+tabs = { git = "https://github.com/mozilla/application-services", rev = "5fc8ee2f0f6950e36d4096983757bd046d55df9f" }
+viaduct = { git = "https://github.com/mozilla/application-services", rev = "5fc8ee2f0f6950e36d4096983757bd046d55df9f" }
+webext-storage = { git = "https://github.com/mozilla/application-services", rev = "5fc8ee2f0f6950e36d4096983757bd046d55df9f" }
+
+# Patch mio 0.8.8 to use windows-sys 0.52 (backport https://github.com/tokio-rs/mio/commit/eea9e3e0c469480e5c59c01e6c3c7e5fd88f0848)
+mio_0_8 = { package = "mio", git = "https://github.com/glandium/mio", rev = "9a2ef335c366044ffe73b1c4acabe50a1daefe05" }
+
+# Patch mio 0.6 to use winapi 0.3 and miow 0.3, getting rid of winapi 0.2.
+# There is not going to be new version of mio 0.6, mio now being >= 0.7.11.
+[patch.crates-io.mio]
+path = "third_party/rust/mio-0.6.23"
+
+[patch."https://github.com/mozilla/uniffi-rs.git"]
+uniffi = "=0.25.3"
+uniffi_bindgen = "=0.25.3"
+uniffi_build = "=0.25.3"
+uniffi_macros = "=0.25.3"
+weedle2 = "=4.0.0"