summaryrefslogtreecommitdiffstats
path: root/browser/build.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /browser/build.mk
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'browser/build.mk')
-rw-r--r--browser/build.mk46
1 files changed, 46 insertions, 0 deletions
diff --git a/browser/build.mk b/browser/build.mk
new file mode 100644
index 0000000000..450ed3c5d2
--- /dev/null
+++ b/browser/build.mk
@@ -0,0 +1,46 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+package:
+ @$(MAKE) -C browser/installer
+
+package-compare:
+ @$(MAKE) -C browser/installer package-compare
+
+stage-package:
+ @$(MAKE) -C browser/installer stage-package
+
+install::
+ @$(MAKE) -C browser/installer install
+
+source-package::
+ @$(MAKE) -C browser/installer source-package
+
+upload::
+ @$(MAKE) -C browser/installer upload
+
+source-upload::
+ @$(MAKE) -C browser/installer source-upload
+
+hg-bundle::
+ @$(MAKE) -C browser/installer hg-bundle
+
+wget-en-US:
+ @$(MAKE) -C browser/locales $@
+
+merge-% installers-% langpack-% chrome-%:
+ $(MAKE) -C browser/locales $@
+
+ifdef ENABLE_TESTS
+# Implemented in testing/testsuite-targets.mk
+
+mochitest-browser-chrome:
+ $(RUN_MOCHITEST) --flavor=browser
+ $(CHECK_TEST_ERROR)
+
+mochitest:: mochitest-browser-chrome
+
+.PHONY: mochitest-browser-chrome
+
+endif