summaryrefslogtreecommitdiffstats
path: root/browser/fxr
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-15 03:35:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-15 03:35:49 +0000
commitd8bbc7858622b6d9c278469aab701ca0b609cddf (patch)
treeeff41dc61d9f714852212739e6b3738b82a2af87 /browser/fxr
parentReleasing progress-linux version 125.0.3-1~progress7.99u1. (diff)
downloadfirefox-d8bbc7858622b6d9c278469aab701ca0b609cddf.tar.xz
firefox-d8bbc7858622b6d9c278469aab701ca0b609cddf.zip
Merging upstream version 126.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'browser/fxr')
-rw-r--r--browser/fxr/content/fxrui.js6
1 files changed, 3 insertions, 3 deletions
diff --git a/browser/fxr/content/fxrui.js b/browser/fxr/content/fxrui.js
index dd0f55767a..641f3cd126 100644
--- a/browser/fxr/content/fxrui.js
+++ b/browser/fxr/content/fxrui.js
@@ -98,7 +98,7 @@ function setupBrowser() {
"nsIWebProgressListener",
"nsISupportsWeakReference",
]),
- onLocationChange(aWebProgress, aRequest, aLocation, aFlags) {
+ onLocationChange() {
// When URL changes, update the URL in the URL bar and update
// whether the back/forward buttons are enabled.
urlInput.value = browser.currentURI.spec;
@@ -106,7 +106,7 @@ function setupBrowser() {
backButton.disabled = !browser.canGoBack;
forwardButton.disabled = !browser.canGoForward;
},
- onStateChange(aWebProgress, aRequest, aStateFlags, aStatus) {
+ onStateChange(aWebProgress, aRequest, aStateFlags) {
if (aStateFlags & Ci.nsIWebProgressListener.STATE_STOP) {
// Network requests are complete. Disable (hide) the stop button
// and enable (show) the refresh button
@@ -153,7 +153,7 @@ function setupNavButtons() {
"ePrefs",
];
- function navButtonHandler(e) {
+ function navButtonHandler() {
if (!this.disabled) {
switch (this.id) {
case "eBack":