summaryrefslogtreecommitdiffstats
path: root/browser/fxr
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-15 03:34:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-15 03:34:50 +0000
commitdef92d1b8e9d373e2f6f27c366d578d97d8960c6 (patch)
tree2ef34b9ad8bb9a9220e05d60352558b15f513894 /browser/fxr
parentAdding debian version 125.0.3-1. (diff)
downloadfirefox-def92d1b8e9d373e2f6f27c366d578d97d8960c6.tar.xz
firefox-def92d1b8e9d373e2f6f27c366d578d97d8960c6.zip
Merging upstream version 126.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'browser/fxr')
-rw-r--r--browser/fxr/content/fxrui.js6
1 files changed, 3 insertions, 3 deletions
diff --git a/browser/fxr/content/fxrui.js b/browser/fxr/content/fxrui.js
index dd0f55767a..641f3cd126 100644
--- a/browser/fxr/content/fxrui.js
+++ b/browser/fxr/content/fxrui.js
@@ -98,7 +98,7 @@ function setupBrowser() {
"nsIWebProgressListener",
"nsISupportsWeakReference",
]),
- onLocationChange(aWebProgress, aRequest, aLocation, aFlags) {
+ onLocationChange() {
// When URL changes, update the URL in the URL bar and update
// whether the back/forward buttons are enabled.
urlInput.value = browser.currentURI.spec;
@@ -106,7 +106,7 @@ function setupBrowser() {
backButton.disabled = !browser.canGoBack;
forwardButton.disabled = !browser.canGoForward;
},
- onStateChange(aWebProgress, aRequest, aStateFlags, aStatus) {
+ onStateChange(aWebProgress, aRequest, aStateFlags) {
if (aStateFlags & Ci.nsIWebProgressListener.STATE_STOP) {
// Network requests are complete. Disable (hide) the stop button
// and enable (show) the refresh button
@@ -153,7 +153,7 @@ function setupNavButtons() {
"ePrefs",
];
- function navButtonHandler(e) {
+ function navButtonHandler() {
if (!this.disabled) {
switch (this.id) {
case "eBack":