summaryrefslogtreecommitdiffstats
path: root/build/rust/goblin/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-15 03:35:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-15 03:35:49 +0000
commitd8bbc7858622b6d9c278469aab701ca0b609cddf (patch)
treeeff41dc61d9f714852212739e6b3738b82a2af87 /build/rust/goblin/Cargo.toml
parentReleasing progress-linux version 125.0.3-1~progress7.99u1. (diff)
downloadfirefox-d8bbc7858622b6d9c278469aab701ca0b609cddf.tar.xz
firefox-d8bbc7858622b6d9c278469aab701ca0b609cddf.zip
Merging upstream version 126.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'build/rust/goblin/Cargo.toml')
-rw-r--r--build/rust/goblin/Cargo.toml19
1 files changed, 17 insertions, 2 deletions
diff --git a/build/rust/goblin/Cargo.toml b/build/rust/goblin/Cargo.toml
index 52e8dfe66d..4b6ea811e9 100644
--- a/build/rust/goblin/Cargo.toml
+++ b/build/rust/goblin/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "goblin"
-version = "0.6.999"
+version = "0.7.999"
edition = "2018"
license = "MIT/Apache-2.0"
@@ -8,4 +8,19 @@ license = "MIT/Apache-2.0"
path = "lib.rs"
[dependencies.goblin]
-version = "0.7.0"
+version = "0.8.0"
+
+default-features = false
+
+[features]
+alloc = ["goblin/alloc"]
+archive = ["goblin/archive"]
+default = ["goblin/default"]
+elf32 = ["goblin/elf32"]
+elf64 = ["goblin/elf64"]
+endian_fd = ["goblin/endian_fd"]
+mach32 = ["goblin/mach32"]
+mach64 = ["goblin/mach64"]
+pe32 = ["goblin/pe32"]
+pe64 = ["goblin/pe64"]
+std = ["goblin/std"]