summaryrefslogtreecommitdiffstats
path: root/build/rust/hashbrown/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:35:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:35:29 +0000
commit59203c63bb777a3bacec32fb8830fba33540e809 (patch)
tree58298e711c0ff0575818c30485b44a2f21bf28a0 /build/rust/hashbrown/Cargo.toml
parentAdding upstream version 126.0.1. (diff)
downloadfirefox-59203c63bb777a3bacec32fb8830fba33540e809.tar.xz
firefox-59203c63bb777a3bacec32fb8830fba33540e809.zip
Adding upstream version 127.0.upstream/127.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'build/rust/hashbrown/Cargo.toml')
-rw-r--r--build/rust/hashbrown/Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/build/rust/hashbrown/Cargo.toml b/build/rust/hashbrown/Cargo.toml
new file mode 100644
index 0000000000..be365ea103
--- /dev/null
+++ b/build/rust/hashbrown/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "hashbrown"
+version = "0.13.999"
+edition = "2021"
+
+[lib]
+path = "lib.rs"
+
+[features]
+# N.B., not using `hashbrown/default` because it includes `hashbrown/allocator-api2`, which we want
+# to avoid.
+default = ["ahash", "inline-more"]
+ahash = ["hashbrown/ahash"]
+inline-more = ["hashbrown/inline-more"]
+raw = ["hashbrown/raw"]
+
+[dependencies.hashbrown]
+version = "0.14.3"
+default-features = false