summaryrefslogtreecommitdiffstats
path: root/dom/webgpu/tests/cts/checkout/src/demo/subcases.spec.ts
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /dom/webgpu/tests/cts/checkout/src/demo/subcases.spec.ts
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dom/webgpu/tests/cts/checkout/src/demo/subcases.spec.ts')
-rw-r--r--dom/webgpu/tests/cts/checkout/src/demo/subcases.spec.ts38
1 files changed, 38 insertions, 0 deletions
diff --git a/dom/webgpu/tests/cts/checkout/src/demo/subcases.spec.ts b/dom/webgpu/tests/cts/checkout/src/demo/subcases.spec.ts
new file mode 100644
index 0000000000..6b22463f07
--- /dev/null
+++ b/dom/webgpu/tests/cts/checkout/src/demo/subcases.spec.ts
@@ -0,0 +1,38 @@
+export const description = 'Tests with subcases';
+
+import { makeTestGroup } from '../common/framework/test_group.js';
+import { UnitTest } from '../unittests/unit_test.js';
+
+export const g = makeTestGroup(UnitTest);
+
+g.test('pass_warn_fail')
+ .params(u =>
+ u
+ .combine('x', [1, 2, 3]) //
+ .beginSubcases()
+ .combine('y', [1, 2, 3])
+ )
+ .fn(t => {
+ const { x, y } = t.params;
+ if (x + y > 5) {
+ t.fail();
+ } else if (x + y > 4) {
+ t.warn();
+ }
+ });
+
+g.test('DOMException,cases')
+ .params(u => u.combine('fail', [false, true]))
+ .fn(t => {
+ if (t.params.fail) {
+ throw new DOMException('Message!', 'Name!');
+ }
+ });
+
+g.test('DOMException,subcases')
+ .paramsSubcasesOnly(u => u.combine('fail', [false, true]))
+ .fn(t => {
+ if (t.params.fail) {
+ throw new DOMException('Message!', 'Name!');
+ }
+ });